Echo Devices (Alexa) as Media Player - Testers Needed


  1. Is there a way to know when a echo device has completed a TTS message using homeassistant?

  2. Amazon plugs are not getting integrated. How to integrate Amazon plugs?

  3. Songs from AMAZON_MUSIC is not playing if linked to an Indian account. Is there a way to play songs from AMAZON_MUSIC while staying with Indian account?

Kindly help

  1. no, not as far as i know. but if you use announcement the next command is done after the announcement.
  2. amazon plugs are normally zigbee or wifi, so automate/intergrate them in another way not through amazon.
  3. i got not clue what an indian account is. i think you can only play amazon music on amazon devices, devices connected to amazon devices or devices that have an amazon app.
  1. I tried… the next action is executed while alexa is still announcing… any way to check is previous action/command has finished.

  2. Any guidance or tutorial on how to do this?

  3. If I switch to Amazon US. I can send command to play music thru HA on my echo devices, and the music selection is done from amazon_music. But if I change the location to india fromm amazon account. Then I am not able to send commands to play music from HA

  1. no, because amazon doesnt send a message when the announcement is finished. if you send 2 announcements they will come after each other, but if you send an announcement and want a light to turn on AFTER that, then there is no way. youll need to calculate the time yourself.

  2. depends on what type of plugs you got. if they are zigbee then youll need another zigbee hub or zigbee coordinator and then use zigbee2mqtt or zha. if they are wifi youll need to check the integration for that brand in HA.

  3. you will need to connect both amazon accounts with HA, to be able to send commands to both accounts. personally i think its best just to use only 1 account with amazon if you want to automate.

  1. Yes… using a delay in between.

  2. This is the plug. The plug is from Amazon only. (Amazon Smart Plug, for home automation, Works with Alexa- A Certified for Humans Device

Any idea how to add this to HA.

  1. Got it…

Thanks a lot for the clarifications.

The made for Alexa plugs can’t really be integrated directly into Home Assistant:

1 Like

Thanks a lot for links… really appreciate it.

i didnt even know that existed. but thats wifi and you are depending on the control from the brand, so in this case amazon, who doesnt release its api yet.

i would integrate it the same way as in the second link digeridew gave you.

Yes… really thanks a lot for your support

Hi, from time to time since a few weeks I receive this error:

Logger: homeassistant.components.alexa.state_report
Source: components/alexa/
Integration: Amazon Alexa (documentation, issues)
First occurred: 6. Mai 2022, 21:28:20 (3 occurrences)
Last logged: 6. Mai 2022, 21:28:20

Error when sending ChangeReport for light.wohnzimmer to Alexa: THROTTLING_EXCEPTION: Request could not be processed due to throttling.

Everything works fine. At least I cannot notice any strange behavior.
Can somebody explain what that is?

It’s not related to this custom component.

OK, then it comes from the cloud integration. Thanks


is it not possible to listen to the “ResponseNone” Event?

i tried it with this code

platform: event
event_type: alexa_actionable_notification
  event_id: actionable_notification_firetv_kueche_switch_off
  event_response_type: ResponseNone

but the automation get never triggered when alexa get no answer from me.

here is the automation for the question

service: script.activate_alexa_actionable_notification
  text: Hallo, Soll ich die Shield ausschalten?
  event_id: actionable_notification_firetv_kueche_switch_off
  alexa_device: media_player.echo_show_kueche

and in the script is everything correct, the ResponseYes works well.

This isn’t the right thread for this discussion. Try Actionable Notifications via Alexa Media Player - #256 by dbrunt

Please post your question and the entire automation(s) and script(s) over in Actionable Notifications via Alexa Media Player - #256 by dbrunt

Will this work on locally stored MP3? I tried it but no success. I replaced the URL to the local full file path but it did not work.

Amazon has set very specific limits on bitrate and length so you need to make sure your file is properly formatted and isn’t too long. One of the best resources on this topic is Mark Watt’s video: Play a local mp3 file on Alexa Echo dot - #33 by MarkWattTech

I’m having setup issues.
I’ve set MFA for the config app as described, however the Amazon MFA page says to click “time based” in the app setup.
I don’t see that on the HA config for the integration.
When I complete the setup and go to the next screen, it tries to log me in to Alexa however the MFA token that is generated looks to be a static one and not time based (this is my assumption) because I am getting this error:

There was a problem
The One Time Password (OTP) you entered is not valid. Please try again.

what can I do to work around this?

Does anybody know where these errors received after the last restart come from:

Logger: homeassistant.components.light
Source: custom_components/alexa_media/
Integration: Licht (documentation, issues)
First occurred: 17:15:02 (1 occurrences)
Last logged: 17:15:02

Error while setting up alexa_media platform for light
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/", line 249, in _async_setup_platform
    await asyncio.shield(task)
  File "/config/custom_components/alexa_media/", line 78, in async_setup_platform
    account = config[CONF_EMAIL] if config else discovery_info["config"][CONF_EMAIL]
KeyError: 'email'

Have that for sensor, alarm_control and switch platform as well.
Alexa speech output works

Is this after the latest HACS update to 1.25.1?

I have a nightmare with HACS components since the latest upgrade but nothing (thankfully) with AMP

My errors are with lovelace components and I have a consistent error with HACS

Logger: homeassistant.components.websocket_api.http.connection
Source: components/websocket_api/
Integration: Home Assistant WebSocket API (documentation, issues)
First occurred: 20:15:31 (9 occurrences)
Last logged: 20:15:31

[547876251344] Received invalid command: hacs/subscribe

But after re-downloading the components everything works!!
Still get the above error though which has occurred since updating HACS