Home Assistant Community

Echo Devices (Alexa) as Media Player - Testers Needed

alexa
Tags: #<Tag:0x00007f3749d5b6c8>
#2099

Yeah I’ve tried reading the thread and the wiki but I can’t figure it out. Guess I’ll check back in a while.

0 Likes

#2100

Your configuration is wrong.

See

0 Likes

#2101

you are using the “old” way of configuring the component.

Once you have all of the files in the correct locations then add this to your configuration.yaml file (substituting your details):

alexa_media:
  accounts:
    - email: !secret amazon_email
      password: !secret amazon_pass
      url: amazon.com

and you also need to remove the config entry you posted above.

restart and it hopefully will work.

0 Likes

#2102

Thanks, already tried that though. HA won’t start if I use the config you posted:

0 Likes

#2103

Ok, I’m pretty sure your problem is that you copied the code from the github incorrectly.

When you go to the github code page for each file you will find a “raw” button at the top of the code box. Click it. It will then open another window with just the code in it. Copy all of that content and put it into your file and then save it. Do the same for the other files.

restart HA with the correct config code above.

0 Likes

#2104

Sweet, thanks! Away from the computer now but I’ll try when I’m back tomorrow. Again thanks alot :smile:

0 Likes

#2105

just updated mine. getting no errors however my TTS is not playing on my echo devices. it was working fine until this new version.

0 Likes

#2106

I’m pretty sure you’re not supposed to add the word “Alexa,” to the routine.

0 Likes

#2107

Check you entity IDs.

0 Likes

#2108

I know this may be a little off point but, i have been pulling my hair out with the TTS. i can make my alexa spot speak on command with the dev-services tool and have also set up automations which work too, Great, but according to the docs it is possible to use if you use the mini media player to announce messages (https://github.com/kalkih/mini-media-player#tts-object)

however it doesnt seem to be that simple, im getting an error message when i click the send/folderd paper icon

Failed to call service tts/undefined_say.

What am i missing, Thanks in advance

0 Likes

#2109

Do you have the following set up in your card?

tts:
  platform: alexa
0 Likes

#2110

@Richard_Gaunt: In addition to this setup, please note the mini-media-player may not actually support the latest version of the alexa_media component. I don’t know one way or the other. If it doesn’t, you’ll need to work with that team to fix it.

0 Likes

Lovelace: Mini Media Player
#2111

What can you do with that in the minimediaplayer lovelace card?
Does it show you the tts message that was send last to alexa?

0 Likes

#2112

When i include
tts:
platform: alexa
i get an error in my config when checking???

0 Likes

#2113

I haven’t used it, but my understanding is it exposes a TTS box in the player that recognizes how to use alexa_tts. The default card assumes you have a tts component which can pass a file to the media_player which won’t work for Alexa.

Please set the config settings in the mini-media-player card.
Please properly quote the relevant configuration so we at least have a chance to debug the problem. Without proper quotes and context of where you put it, it’s nearly impossible to debug. I can’t tell if you made changes to the alexa_media platform, which is the completely wrong place or the mini-media-player card. I also can’t tell if you have the right indentations or not.

0 Likes

#2114

Worked like charm, thanks alot! I had no idea you couldn’t just download the files directly :stuck_out_tongue:

0 Likes

#2115

Hi, i will try again, my config looks like this:-
tts: platform: alexa

The error message i get when checking is

Platform not found: tts.alexa

Log Details (ERROR) Sun Mar 03 2019 11:16:04 GMT+0000 (Greenwich Mean Time) INFO:homeassistant.util.package:Attempting install of colorlog==4.0.2 Testing configuration at /config Failed config General Errors: - Platform not found: tts.alexa Successful config (partial)

My mini -media-player looks like:-
artwork: cover entity: media_player.richard_s_echo_spot hide: power_state: false source: true volume: true icon: 'mdi:amazon-alexa' tts: alexa type: 'custom:mini-media-player'

0 Likes

#2116

I always downloaded the files directly and it worked for me every time. Don’t see the difference.

0 Likes

#2117

Just tested:

  "entity_id": "all",
  "media_content_id": "qmusic",
  "media_content_type": "TUNEIN"`

This works to let TUNEIN play on all of my Echo Dot’s

0 Likes

#2118

Invalid config, should look like this:

- type: custom:mini-media-player
  entity: media_player.echo
  tts:
    platform: alexa

@alandtse Did anything change with the alexa_tts service call in or after v1.0.0? Doesn’t seem like it from reading the docs.
Some users can’t seem to get tts working together with the mini-media-player card anymore. Could be caused by invalid card configurations, but I can’t test myself since I got no echo devices.

0 Likes