Echo Devices (Alexa) as Media Player - Testers Needed

Tags: #<Tag:0x00007fd0856cfb80>


it depends on what you mean by “download”. If you mean going to the github and clicking on the “clone or download” button and then copy the files to the correct location then that will work too.


Just tested it. I’m on the latest version of this component and also your card. TTS works for me on my echo plus using the mini-media-player card.

Lovelace: Mini Media Player

This is exactly the way I do it. Download zip file. Didn’t there is a wrong way to download the files.

Could you explain what this does in the miniplayer? Don’t have it and I’m interessted how you use it? What can you do with it? Advantage compared to the normal mediaplayer.


Some people go to the github code listing and copy/paste directly from there and think they are “downloading” the file. But what they are doing is copying an html page and that’s what causes issues.

Downloading by the button or copying the “raw” code are generally functionally equivalent.


I don’t use the mini-media-player for tts. I just tested it to help out.


Ok, maybe someone else can say what this is able to do.

@alandtse another quick question. Is it possible to use tts with the fire stick too? I tried it my calling a routine and turning on my input boolean with that and then it should answer, but it didn’t.
Echo devices work. Also last_alexa sensor picked the fire stick as the right last device, but it seems tts is not working for the stick.

Can someone confirm that?


Had the issue that one of my alexas was way to quiet. My standard volume was set to 0.3. This is ok for most devices but not for an echo dot second gen.

Just want to share what I came up with, to set different volumes using the last_alexa sensor:

    - service: media_player.volume_set
        entity_id: '{{ states.sensor.last_alexa.state }}' 
        volume_level: >
          {% if is_state("sensor.last_alexa", "media_player.echo_dot_second_gen") %}
          {% else %}
          {% endif %} 

Hope that helps someone. With an elif you could also add other echo to get a certain value.
You have to call that script before you send the tts service.


It allows you to have a tts input directly on the card, nothing special.



Thanks for testing :pray:


On my behaviour it works if i call the service directly from the dev service, but it doesn’t work if i try to call this from the frontend (i.e. from the card directly). I always get ‘failed to call media_player/alexa_tts service’.

Lovelace: Mini Media Player

i dont think its possible, because you cant use it in the app.
you cant send a text to the stick with a routine.

and you can ALWAYS check if something is possible by trying it in the app.
if you CANT do it with the app, you cant do it with HA.


You are right, did not think of that.

Trying that, the fire stick answers that “this service is not available yet”.


I added the two sections

Setting the volume for the last called device at a certain level


Send a tts to the last called alexa device

here :

Maybe someone with english as his/her mother-tongue could read through it and correct it.


Anybody has any lagging problem about the state changing in the HA?
When I change any state ( radio station, a music in the Spotify, volume, etc.) the state is not changed, sometimes changes with lot of delays sometimes the previous state remains in the HA and Hadashboard too. It is true for the mini mediaplayer and the native mediaplayer too.


The overall platform changed from media_player to alexa_media.media_player so I don’t know if the UI card used that platform name. The entities should remain as media_player.echo. The TTS service is still media_player.alexa_tts but we will probably deprecate that after changing it to a notify service.

If it works in the service, you may need to share the exact service call you’re using to @kalkih as I think it’s with the card.

@kalkih, on another note, would there be any benefit if we exposed the playlist queue or the history to your UI? I’ve been meaning to see if any media_player UIs actually would use that data if we exposed it. I don’t think it’s actually in any media_player UIs right now but perhaps you’d know.

What version of the component are you using? As of the 1.x.y branch, we reduced the scan_interval frequency so it’ll take up to a minute to determine a media_player is in use if you’re interacting with Alexa outside of HA. Interacting with alexa_media in HA will do it immediately (e.g., calling alexa_media.update_last_called).


Thanks for the info, it does seem to be working as expected when the correct card config is provided based on feedback I got. :+1:

Not sure, I probably wouldn’t use it since I try to keep the mini-media-player card pretty simple.
I Haven’t seen it being used anywhere neither but could be a cool thing to have in potential upcoming custom/core media cards in the future.


I am having issues with the 1.0.0 version of the component. (First time installation for the component). It seems that I should be getting some Capcha configurator, but I can’t tell where that should be showing up. I don’t see it anywhere. I see that there’s an entity for the captcha configurator, but I’m clueless as to where it should be. I also can’t see any of my Alexa devices, but I don’t see any information in the logs about any issues.



I think I use the last one:

I have tried with 30 sec scan interval (from the docs) but the result was same.

    - email: [email protected]
      password: mysecretpw
      #scan_interval: 30


Maybe the problem caused by the Spotify media player because my Echo used with it also, therefore it is detected as outside of HA. What do you thing about it?


@kalkih you sir have solved it for me brilliant


Check the notifications pane in the top right of HA. It’s a little bell next to the microphone and UI options.

Yes, if you’re controlling through Spotify, you’re reliant on the polling mechanism to pick it up. The configuration you posted has a # which is commenting out the scan_interval. Remove the # if you want to set the value.