Echo Devices (Alexa) as Media Player - Testers Needed

alexa
Tags: #<Tag:0x00007fd0794f7760>

#2179

I found this in the thread above

"data": {
        "entity_id":"media_player.YOUR_ECHO_DOT",
        "media_content_id":"silence 5 seconds",
        "media_content_type": "AMAZON_MUSIC"
}

If you search and find a dingdong sound on amazon_music, you could replace that.

basically something simple like
trigger:
door opens
action:
the command to play a “song” to your alexa, and use the info above for the parameters


#2180

I also thought about this, but couldn’t find a ding dong sound on amazon music.


#2181

I just went to amazon music and searched for “sounds ding dong” there looks to be an album called DV Sound effects" and one of the sounds is doorbell ding dong. not sure how good or bad it is, but it looks like it might be what you need

edit: thanks, there are a lot of fun sound effects here, now I think I’m going to have to set up some silly automations!! haha


#2182

Unfortunately those sounds are only included in amazon prime unlimited and I don’t have that.


#2183

I dont have prime unlimited (I do have prime), and they play for me


#2184

Looks like “DV sound effects” is in unlimited in my country.


#2185

This album seems good for sounds and is on Prime but not unlimited in the UK:

“Alarms, Buzzes, Buttons, Switches, Clocks, Telephones Ringing” by Sound Effects on Amazon Music. https://music.amazon.co.uk/albums/B003458LDQ?ref=dm_sh_P0CCF808IIaj3q0Iv2AJhTPQK

this works fine for me

{
  "entity_id": "media_player.echo_show",
  "media_content_id":"Warning Alarm Siren 3",
  "media_content_type": "AMAZON_MUSIC"
}

#2186

Try finnolia sound effects? If that does not work, maybe another music service you have access to. I’ll stop posting for now, since this is more of a “where can I find a sound effect” and less of a “how” at least as far as help I can offer. Good luck, if you find the sound, and create the automation, go ahead and post for others.


#2187

Hi everyone, running into some issues with the configuration. I am based in the US and have 2FA enabled on my Amazon account. I am running .88.2 on RPI. I have followed instructions from this link for versions > 1.0. The component shows in HA waiting to be configured. I get this prompt :

.
2 issues here : first it is asking me to re-enter the password. Not sure where ? Second the CAPTCHA is actually missing. Now, I can enter anything, submit, and then press “Configuration” again, this time I do see a CAPTCHA, I enter it but then back to the same state again.

My config file has :

image

In secrets I have my username and password contained in “”. I have tried without “”, does not seem to make a difference.

Any suggestions ?

Thanks !


#2188

It is possible to create a routine to play music from “My Library”. Not sure what “My Library” is, but if you could get the sound you want into “My Library”, maybe you could just trigger the routine from HA. Of course it may require a one time fee to purchase the sound to put into “My Library”.


#2189

You’re failing the captcha according to Amazon. You should try again. If you want to see more info, turn on debugging.

EDIT: The reason you’re always failing the captcha is because you’re trying to login as secret! amazon_user. Fix your config to use !secret correctly.

alexa_media:
  accounts:
    - email: !secret amazon_user
      password: !secret amazon_password
      url: amazon.com

#2190

Thanks @alandtse. I changed my config file removing the !secret and replacing with my actual email and password, rebooted and got the same result. The first captcha with no image asking to re-enter my password, then failing all CAPTCHAs. Not sure what I am doing wrong. Also, sorry if this is basic, but I do not see what is different between my original config I pasted and the one you edited…:slight_smile: Thanks for your help !


#2191

!secret vs secret!


#2192

Doh…sorry…thank you


#2193

Thanks @alandtse, after correcting my mistake on the use of secrets syntax and removing the " " both username and password in the Secrets file, I successfully configured. I did get the first CAPTCHA prompt with a blank image, clicked through then hit configure again, this time it came up with a CAPTCHA image and it worked. I received a text on my phone with the Amazon code, entered that and…success…thank you.


#2195

Is it possible to rename the “this device” device. I don’t mean a friendly name. I mean changing it in the alexa app, so that the media player entity shows up different. “This device” is a bad name.


#2196

i don´t understand what to do. i changed name of folders and files back and forth. no change. what am i supposed to do after updating to 0.89?

BR Mathias


#2197

Please follow these instructions exactly. You should update to 1.1.0 per the instructions. We are not supporting any lower version (e.g., 0.10.2) and with HA releasing breaking changes, there may be issues we probably won’t fix .


#2198

So is there a new alexa_media component? When I check my configuration it says Component not found: alexa_media


#2199

I followed those directions exactly and homeassistant isn’t even seeing the custom component in 0.89.1. There is no errors in the logs or anything.

I am also not sure what you mean by “there may be issues we probably won’t fix”. Has this project been abandoned?