Echo Devices (Alexa) as Media Player - Testers Needed

alexa
Tags: #<Tag:0x00007f4806c140a8>

#1287

OK but I can get to alexa speak through my echo plus. I always get “Eso no lo se” message in spanish what meaning Sorry I dont know it in english when I try send text in state home assistant section


#1288

Have you tried amazon.es in your configuration.yaml such as:

media_player:
  - platform: alexa
    email: “your amazon email”
    password: “your amazon password”
    url: “amazon.es”

Perhaps you could reply to this guy, @robermf, who has successfully used amazon.es?


#1289

Yes I have just tried but no exit. Only works with amazon.com and amazon.com.mx but tts still not working. Alexa says he same error phrase


#1290

you probably have the same problem as the italian users.
in the alexa app in routines can you make it that she speaks a custom text?
if not, then TTS is not going to work.


#1291

I cannot set a custom text to make Alexa speak with routines, so what does it means?


#1292

I think @ReneTode is right. From Alexa wiki page I can see that Echo devices have same availability start date for Italy and Spain so we may have same problem on TTS: we don’t have (yet) custom text speaks in routines


#1293

that you cant use tts in italian


#1294

Hello!
I had the same problem but finally it was easy: Use media_player.alexa_tts instead google_tts

Try with this script:
alexa_habla:
alias: Alexa Habla Test
sequence:
- service: media_player.alexa_tts
data:
entity_id: media_player.name_of_your_echo
message: “Hola. Probando. Uno dos tres.”

And your Echo should speak Spanish with this.

Good luck!

(I use amazon.es)


#1295

Hey @robermf, so you can use tts in Spanish? Is your account a Spanish account?


#1296

Hi.
Yes, I am using tts in Spanish with Spanish account :slight_smile: @Nerkyator

Here configuration.yaml:
media_player:

But it does not work from the media player box in Home Assistant. But if you use madia_player.alexa_tts it works.
You can test quickly with this:
Go to Events http://192.168.0.X:8123/dev-event

Event type:
media_paplayer.alexa_tts

Event data:
{“entity_id”: “media_player.your_echo”, “message”: “Hola que tal probando uno dos tres cuatro hola hola que tal”}

Best regards


#1297

Hmmm i tried with italian language but it doesn’t work!


#1298

Can you tell me why i always get these errors?

2018-11-29 14:40:02 ERROR (Thread-13) [custom_components.media_player.alexa] An error occured accessing the API: An exception of type ConnectionError occurred. Arguments:
(ProtocolError('Connection aborted.', ConnectionResetError(104, 'Connection reset by peer')),)
2018-11-29 14:40:02 ERROR (Thread-13) [custom_components.media_player.alexa] An error occured accessing the API: An exception of type AttributeError occurred. Arguments:
("'NoneType' object has no attribute 'json'",)

#1299

Thanks @robermf! I will try when at home with Italian server & account and I will give feedback


#1300

I already tried but with no success… if you get it working please let me know…
More, did you get the errors i put in my previous message?


#1301

Do you know how to get again the request of the token ? I never got that when configuring the media player


#1302

Yep! Just checked your error and seems that something somewhere returns None instead a value where to extract json object.
I will try on my HA when at home and I’ll let you know!


#1303

Maybe it can depend from the never requested token at first time the media player was configured?
How to get again that request?


#1304

Good luck! Let me know

@mauizio53: Sorry to hear that. You can see the Alexas as media players in Home Assistant, right?


#1305

Yes, i have two alexa media players, echo plus and spot


#1306

Pfff I don’t know… Try to restart.

By the way, I had to put the captcha right now for first time after first install (few weeks ago)