Echo Devices (Alexa) as Media Player - Testers Needed

alexa
Tags: #<Tag:0x00007f480214f8d8>

#1307

How did you got the request for the token?


#1308

I’m pretty sure the access has to be re-verified every so often.

I’ve had to do it a couple of times since I first installed this. Just had to do it 20 minutes ago in fact. That’s only the second time so far.


#1309

I never got that verifying request… how to have it again, i read we must delete a file but don’t know which one…


#1310

No Luck :frowning:
Following your suggestion (same as main post on this topic) it still returns me only an error sound and nothing else. Alexa TTS seems to be only an Italian problem…I think we have to wait for them :zipper_mouth_face:


#1311

Ok I will try thanks. Another question. Do you have enable custom alexa tts into routines in alexa app?


#1312

I’m pretty sure the verification files are stored in the 'alexa_media.pickle" file in your main config directory and in the “alexa.cpython-36.pyc” file in the “custom_components/media_player/pycache” folder.


#1313

dont wait untill others start looking for you.
it has been said in this topic (might be 200 reaktions back) so start reading back if you think it is worth it.


#1314

And we can safely delete them to get a new captcha?


#1315

I’m pretty certain that will work. I had to do that during troubleshooting when I couldn’t get the component to work. See my posts regarding that WAY up above starting in the beginning of august (i think).

What I would do just to be safe is rename those files by adding a “.old” to the end.

Then if something goes wrong you still have original files.


#1316

By the way, I am also using Home Assistant Cloud for integrate Alexa. Just in case…

@NDNELSON What you mean about custom Alexa tts into routines in Alexa app? Use Alexa TTS directly from the phone app??


#1317

right.
in the alexa app, in routines, you should be able to set a custom text spoken by alexa.
if thats not possible there, then TTS cant be used.


#1318

yes directly in app because Nerkyator told that:


#1319

there are 2 possible reasons why TTS isnt working:

  1. there is something wrong at the amazon servers
  2. there is something wrong in the setup or actions from a user.

we know that italian users have to deal with a missing part on the amazon servers.
at the moment a spanish user told he had a problem that tts wasnt working but alexa did respond something i suspected that the same problem was on the spanish server. Nerkyator came to the same conclusion because of the facct that italian and spanish servers were released at the same time.

afterwards a spanish user told that it is working.
if it is working for 1 spanish user then the problem cant be on the spanish amazon server.

thats why we know that if a spanish person has trouble with TTS, its something in his setup.

so until now everyone can use TTS, except the people who use the italian server.


#1320

Hi.
I tried to find how to do it from routines and I couldn’t. Plus… I am out of home and trying to listen Alexa from IPCAM in the next room (hoping my friend does not get up scared :smiley: )

So… I go to Routines in Alexa app, y tap on + to create a new one.
WHEN: I can choose between Voice, Time and Device
ACTION: A few options and inside Devices I can choose the Alexa media_players from Home Assistant.

How can I check that?

From Home Assistant I am already using media_player.alexa_tts in Spanish for messages for the alarm and other automations. If someone wants I can upload a video or audio…

Using Text to Speak from the box of the media player it didnt work for me. I think because it uses google_say.


#1321

Something weird again.

First this afternoon I had to type the captcha… First time after installation. In the same moment I came here.

Now I was trying Text to Speak box in the media player window in Home Assistant. When I tried a few weeks ago Alexa only said “Lo siento, pero no puedo hacer eso que me pides” = “Im sorry, I can’t help you” or something like that in Spanish.
Now I have tried with “Hola” and Alexa is answering in ENGLISH “Sorry…bla bla… Alexa tts service”. I can’t hear well (im out of home listening through IPCAM placed in the next room.

When I use Text to Speak from there (the window of the media player in Home Assistant) I see “Servicio tts/google_say llamado” in the bottom left corner of the browser.

Using Alexa_tts service is working fine.


#1322

ok an do you modify something in alexa.py file to alexa speaks spanish?


#1323

I was trying different things without success. But I think I am using the original Alexa.py . Anyway I upload mine here (just remove .yaml, I need to add to can upload here)
Also I am using Home Assistant Cloud to integrate Alexa. What method are you using? I dont know if it is important.
And I tried to use this method without success: https://www.youtube.com/watch?v=XuL4nqGDxX4&frags=pl%2Cwn

I gave up and after vacations it was working using media_player.alexa_tts service.

I’d like can help more

alexa.py.yaml (42.6 KB)


#1324

I already have the files of this method https://github.com/walthowd/ha-alexa-tts in my config director

I can’t see how this script could be related but just in case:

In Alexa_remote_control.sh I have:

# EMAIL and PASSWORD are set on the keys 'alexa_email' and 'alexa_password'

in your secrets.yaml file.

#SECRETS_YAML=’/home/homeassistant/.homeassistant/secrets.yaml’
SECRETS_YAML=’/config/secrets.yaml’

#LANGUAGE=“de-DE”
#LANGUAGE=“en-GB”
LANGUAGE=“es-ES”

#AMAZON=‘amazon.de
#AMAZON=‘amazon.co.uk
AMAZON=‘amazon.es’

#ALEXA=‘layla.amazon.de
ALEXA=‘layla.amazon.de
#ALEXA=‘pitangui.amazon.com

binaries

CURL=’/usr/bin/curl’
AWK=’/usr/bin/awk’
SED=’/bin/sed’

And in secrets.yaml my login and password still there. Its late and I am a little bit confused… I dont think that this is related but I can’t figure out where is the problem
I remember I was trying different things and I couldn’t config it right. Later I installed the component of this thread. But it was a few weeks ago…


#1325

yo have this in alexa.py :

data = {
“behaviorId”: “PREVIEW”,
“sequenceJson”: “{”@type":
“com.amazon.alexa.behaviors.model.Sequence”,
“startNode”:{"@type":
“com.amazon.alexa.behaviors.model.OpaquePayloadOperationNode”,
“type”:“Alexa.Music.PlaySearchPhrase”,“operationPayload”:
{“deviceType”:"" + self._device._device_type + “”,
“deviceSerialNumber”:"" + self._device.unique_id +
“”,“locale”:“es-ES”,
“customerId”:"" + self._device._device_owner_customer_id +
“”, “searchPhrase”: “” + search_phrase + “”,
“sanitizedSearchPhrase”: “” + search_phrase + “”,
“musicProviderId”: “” + provider_id + “”}}}",
“status”: “ENABLED”
}

What I notice is that you refer to “”,“locale”:“es-ES”, \ I will try with es-US and es-ES and then I get back with a response about my test. Thanks for the info


#1326

Then I should have changed it.
I was making a lot of tries with the two componentes and after I was two weeks out of home… Sorry for can’t remember from the beginning. Thanks to you for find it (I tried with looking for language now)

Hope she can speaks Italian too using it-IT

Let me know if it works :slight_smile: