Echo Devices (Alexa) as Media Player - Testers Needed

alexa
Tags: #<Tag:0x00007f203c85daf0>

#1673

Thanks Guys but

media_player:
  - platform: alexa
    email: “[email protected]”
    password: “my.password”
    url: “alexa.amazon.co.uk”

Still does not work


#1674

You still are using the incorrect quotation marks. Either use " quotation marks (they do not curl) or remove them.


#1675

Oh sorry I thought your comment was in relation to the incorrectly formatted response form mistrovly!
Will remove quotes and try again.
I only have " ’ as quotes on my mac


#1676

if you use a text only editor it should automatically use the correct quotation marks by default. If you use a rich text editor then you don’t know which you will get.


#1677

hello.
can someone confirm, this works after upgrade ha to 0.85 (and 0.85.1)?


#1678

I use the editor in configuratror in hassio. Worked for all other quotes!


#1679

without quotes still no difference.


#1680

Hello everyone, so i’ve been using this addon for almost a month and everything was working fine until i updated to the latest version. Now i’m getting connection errors

Config entry:

Error Log: https://hastebin.com/rufevevayi.sql


#1681

@knackrack615
Change the url to:

url: amazon.com 

Your logs are complaining the domain isn’t resolving and urllib is giving connection pool errors. You may need to reboot.

@auditdata
Change yours to.:

url: amazon.co.uk

#1682

Still no joy with url: amazon.co.uk.
This is the log? Any clues

2019-01-13 08:36:30 WARNING (MainThread) [homeassistant.loader] You are using a custom component for media_player.alexa which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant.
2019-01-13 08:40:34 WARNING (MainThread) [homeassistant.helpers.entity] Update of media_player.mr_s_fire_tv_stick is taking over 10 seconds
2019-01-13 08:40:35 WARNING (MainThread) [homeassistant.components.media_player] Updating alexa media_player took longer than the scheduled update interval 0:00:10
2019-01-13 08:42:13 WARNING (MainThread) [homeassistant.helpers.entity] Update of media_player.kitchen_sonos is taking over 10 seconds
2019-01-13 08:42:14 WARNING (MainThread) [homeassistant.components.media_player] Updating alexa media_player took longer than the scheduled update interval 0:00:10
2019-01-13 08:44:35 WARNING (MainThread) [homeassistant.helpers.entity] Update of media_player.kitchen_sonos is taking over 10 seconds
2019-01-13 08:47:41 WARNING (MainThread) [homeassistant.helpers.entity] Update of media_player.mr_s_fire_tv_stick is taking over 10 seconds
2019-01-13 08:48:36 WARNING (MainThread) [homeassistant.helpers.entity] Update of media_player.this_device is taking over 10 seconds
2019-01-13 08:48:36 WARNING (MainThread) [homeassistant.components.media_player] Updating alexa media_player took longer than the scheduled update interval 0:00:10
2019-01-13 08:49:19 WARNING (MainThread) [homeassistant.helpers.entity] Update of media_player.clive_s_echo_spot is taking over 10 seconds
2019-01-13 08:49:19 WARNING (MainThread) [homeassistant.components.media_player] Updating alexa media_player took longer than the scheduled update interval 0:00:10
2019-01-13 08:52:01 WARNING (MainThread) [homeassistant.helpers.entity] Update of media_player.mr_s_reverb_ai is taking over 10 seconds
2019-01-13 08:52:02 WARNING (MainThread) [homeassistant.components.media_player] Updating alexa media_player took longer than the scheduled update interval 0:00:10

#1683

Same problem here after update (with amazon.es).


#1684

your log shows that your mediaplayers are created and active.


#1685

I use amazon japan and have no issues…works perfectly. My yaml:

media_player:
   - platform: alexa
     email: !secret alexa_un
     password: !secret alexa_pw
     url: amazon.co.jp

#1686

are you not getting a notification to enter a captcha code?


#1687

Hi,
It seems to be just an issue of time. When I went to check that there were definately no media players in the current entities, low and behold they are now there. All 5 of my Amazon Alexa devices! Sweet. Now to try Text to speech…

My config for interest.

media_player:
  - platform: alexa
    email: !secret amazon_login
    password: !secret amazon_password
    url: "amazon.co.uk"

Thanks for all your help. Time seems to have fixed it!


#1688

That and the correct URL and the proper quotation marks! :wink: :smile:


#1689

After update to 0.85 I am getting this error (same error showed by @knackrack615 )

> Log Details (ERROR)

Sun Jan 13 2019 15:48:59 GMT+0100 (CET)

Error while setting up platform alexa
Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/homeassistant/helpers/entity_platform.py”, line 128, in _async_setup_platform
SLOW_SETUP_MAX_WAIT, loop=hass.loop)
File “/usr/local/lib/python3.6/asyncio/tasks.py”, line 358, in wait_for
return fut.result()
File “/usr/local/lib/python3.6/concurrent/futures/thread.py”, line 56, in run
result = self.fn(*self.args, **self.kwargs)
File “/config/custom_components/media_player/alexa.py”, line 142, in setup_platform
config.get(CONF_DEBUG))
File “/config/custom_components/media_player/alexa.py”, line 608, in init
self.login_with_cookie()
File “/config/custom_components/media_player/alexa.py”, line 631, in login_with_cookie
self.login(cookies=cookies)
File “/config/custom_components/media_player/alexa.py”, line 766, in login
self._data = self.get_inputs(soup)
File “/config/custom_components/media_player/alexa.py”, line 644, in get_inputs
for field in form.find_all(‘input’):
AttributeError: ‘NoneType’ object has no attribute ‘find_all’


#1690

Still problem for me. I tried remove media_player folder and download again alexa.py but promp for cookies doesn’t show up!


#1691

:slight_smile: :wink: :slight_smile: :slight_smile: Thanks


#1692

Hello, after changing my URL to amazon.com as suggested by @alandtse i’m now getting the following

requests.exceptions.MissingSchema: Invalid URL '': No schema supplied. Perhaps you meant http://?