Echo Devices (Alexa) as Media Player - Testers Needed

Tags: #<Tag:0x00007f203dc5f828>


We need the full logs instead of the excerpt to diagnose this. Did you do a reboot like I mentioned earlier?

What version are you using? The latest version does not make that function call at that line. The error you are providing indicates the Amazon page does not have any sign in form fields, so will need more debugging from the component.

Please provide your logs. Your description is not helpful. Did you delete the alexa_media.pickle file from your configuration directory?


I’ve delete all content of folder “custom_component/media_player” (so i’ve deleted script and cookie folder that i don’t remember the name now). Then i’ve redownloaded from github and placed again here. Reboot HA (0.51.1)

Cookies folder now is not generated again by

My log:

Error while setting up platform alexa
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/helpers/”, line 128, in _async_setup_platform
SLOW_SETUP_MAX_WAIT, loop=hass.loop)
File “/usr/lib/python3.5/asyncio/”, line 400, in wait_for
return fut.result()
File “/usr/lib/python3.5/asyncio/”, line 293, in result
raise self._exception
File “/usr/lib/python3.5/concurrent/futures/”, line 55, in run
result = self.fn(*self.args, **self.kwargs)
File “/home/homeassistant/.homeassistant/custom_components/media_player/”, line 146, in setup_platform
File “/home/homeassistant/.homeassistant/custom_components/media_player/”, line 618, in init
File “/home/homeassistant/.homeassistant/custom_components/media_player/”, line 641, in login_with_cookie
File “/home/homeassistant/.homeassistant/custom_components/media_player/”, line 776, in login
self._data = self.get_inputs(soup)
File “/home/homeassistant/.homeassistant/custom_components/media_player/”, line 654, in get_inputs
for field in form.find_all(‘input’):
AttributeError: ‘NoneType’ object has no attribute ‘find_all’


Just wanted to share my experience. I have been using the Alexa Media player without issue for about 3 weeks or so. I use it in combination with AirFoil (and a custom airfoil component) and have a echo dot connected to the line in on my AirFoil Mac - this allows me to have a solution for Sirius XM across all my Apple TVs, Homepods, and Older Airplay speakers in the house. Has been working flawlessly. I have a Lovelace screen for all the speaker zones, some buttons for various SiriusXM channels. Only thing I don’t have is Album art for what is actually playing - it has the channel art, and the song titles…


You’re still not answering his question. Did you delete alexa_media.pickle? It is not located in the folder that you deleted. It is in the config folder.


Sorry I’ve just now found the file, delete it, rebooted and now it’s all ok! thanks


I’ve got it all working quite painlessly and have my two devices showing up as expected. :slight_smile:

I also have the following two devices listed and showing up on the front end too, has anyone else seen that and know what they are and how to use or get ride of them?



that are the mobiles that you use for the alexa app.
they are also in your list of devices from the alexa app, and you can use alexa on those mobiles.


Thanks Rene, that solves the mystery then.

I’d not thought about them being the phones as they (the phones) also show up under the entries for the physical Echoes, but having checked closely, I think those entries are the Bluetooth pairings.

So far, I have new media players for Downstairs group, kitchen, lounge, Alexa Apps and 2x This Device. Not had a chance to check out TTS yet, so I don’t know if the Alexa group will support it.


alexa groups cant use TTS.
and look in the app on your phone and you ll see that its not a bluetooth device. they dont register as alexa able device.

they are really the phones. you get everything that is in the app listed as alexa device.


Hi Rene, please see the snippet below:

The source_list: includes the Bluetooth adapter the device is paired with. The kitchen Echo has our two mobile phones listed there as we’ve paired them over BT.


yup that too.
you can see which devices you have paired.
but bluetooth devices as themselves dont show up as alexa enabled devices.

so media_player.this_device is the alexa app on your mobile.
i am sure about that, because they are in the device list in the alexa app (just check out devices in your alexa app)


That makes sense now. What’s the one that shows up as “'s Alexa Apps”, it seems very basic in the entities?


i havent seen that one.
i know there are 2 different kind of alexa apps.
1 that you can use to control your devices (which also contains the option to speak to) and 1 that only gives you the option to speak to a tablet or mobile. maybe you have installed that somewhere?

what do you mean, it seems very basic in the entities?


It only has a couple of properties:


never seen it.
can you find it in your alexa app in devices (on your phone) as well?

or did you configure something else as mediaplayer in your home assistant config?


Nope, I can’t work that one out either.

The phone lists two entries for ‘Alexa on this phone’, they seem to have basic info there but if you view the About screen it displays serial no. relating to WiFi ID saved to Amazon. Each one is a different serial, which will be because I have the Echoes connected to different SSIDs.


I also have the myname’s Alexa Apps and This Device showed up in HA as media_players. I just hid them since I have no idea what it is and thought maybe a glitch with component.


is there a way to have the alexa do the weather or news brief?
or did i miss it in this 1,700 long thread?


If you’re on 0.9.5 or above, there’s a configuration option to exclude them if you want.

Not in the main version. There’s a pull request to include that functionality written by lubeda but we haven’t merged it in yet.


Any suggestions on a way to switch Amazon accounts after getting it working on one? I delete the pycache folder and updated the login info and restarted (twice) but it’s still showing devices on the old account.