Echo Devices (Alexa) as Media Player - Testers Needed

alexa
Tags: #<Tag:0x00007f0583abe570>

#1713

I did indeed reboot (the whole HA VM in-fact)

Full logs: https://hastebin.com/oxerucofub.sql (Using: amazon.com without quotes)


#1714

@gilweb did you read this a few posts back?


#1715

I’m having troubles with using TTS from the custom card Mini-Media-Player. It has the box to enter in text, and then when I hit submit, nothing happens. Nothing on the echo, no errors, just nothing happens.

I have an automation for my doorbell and that triggers media_player.alexa_tts, and that works fine. I just have no idea if I have missed a step or what has happened.

In my main configuration.yaml file, I have tts: defined, but there is nothing under it.


#1716

I had a look at the mini meda_player custom card code and it looks like the tts setting needs to be set to
alexa


#1717

Is this component not compatible with the newer versions of Hass.io? I’m running 85.1 and all of a sudden the component stopped working. I’m seeing the following in the component log.

There was an error
Internal endpoint:
curl -X POST -d “tts=Ask Alexa team for a proper TTS API” -d “deviceSerialNumber=deviceSerialNumber” http://localhost:8091/alexa-tts

Thoughts anyone?


#1718

I’ve installed this, but its not working for me.

I’ve I login to amazon.es (where I live), I’m able to see all my devices, but all of them are shown as “unavailable” (I think I have an issue with my alexa account, as I bought my original Amazon Echo before it was available in Spain… I’m using Virginia Api instead of Ireland for HAASKA, for example).

I tried to connect to amazon.com instead, but if I do it, it refuses to connect and request me a captcha (that I’m not able to provide, obviously), and if I try alexa.amazon.com, python returns a bunch of errors :(.

Any clue or suggestion about how to proceed?

EDIT: Amazon.co.uk also returns all my devices, but it didn’t work either.

Thanks!


#1719

the best way to go on (in my eyes)
go to alexa.amazon.com and disconnect all your devices there, then delete that account
do the same with amazon.co.uk

the use the alexa phone app to login to alexa.amazon.es and make sure everything is connected and working.
then correct everything you got in HA to let it work with alexa.amazon.es (you might need to delete the cookie file from this component)


#1720

Mine too.
Thanks!


#1721

You are correct. Thanks. That shows a text entry field on the card which works fine. But then inside the card info popup, there is another text entry field. This one doesn’t work.

Thanks anyway. At least I know it’s not this Alexa component having any issues. I’ll move any further questions on over to the mini media card forum post.


#1722

Are you in the right Alexa thread? We don’t use curl in this component.


#1723

Hi!

I removed all the devices from my account, and then I’ve created a new account in alexa.amazon.es, but when I’m trying to use it, I’m getting this error:

2019-01-17 20:50:49 INFO (MainThread) [homeassistant.loader] Loaded media_player. alexa from custom_components.media_player. alexa

2019-01-17 20:50:49 WARNING (MainThread) [homeassistant.loader] You are using a custom component for media_player. alexa which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant.
2019-01-17 20:50:50 INFO (MainThread) [homeassistant.loader] Loaded alexa from homeassistant.components. alexa
2019-01-17 20:50:50 INFO (MainThread) [homeassistant.setup] Setting up alexa
2019-01-17 20:50:50 INFO (MainThread) [homeassistant.setup] Setup of domain alexa took 0.0 seconds.
2019-01-17 20:50:51 INFO (MainThread) [homeassistant.components.media_player] Setting up media_player. alexa
2019-01-17 20:50:52 ERROR (MainThread) [homeassistant.components.media_player] Error while setting up platform alexa
File “/config/custom_components/media_player/ alexa .py”, line 146, in setup_platform
File “/config/custom_components/media_player/ alexa .py”, line 639, in init
File “/config/custom_components/media_player/ alexa .py”, line 662, in login_with_cookie
File “/config/custom_components/media_player/ alexa .py”, line 797, in login
File “/config/custom_components/media_player/ alexa .py”, line 675, in get_inputs

My configuration in configuration.yaml
media_player:

  • platform: alexa
    host: “192.168.1.24”
    email: “[email protected]
    password: “SuperSecretPassword”
    url: “amazon.es”

I’ve several devices, and I’ve tried with and without specifying host :frowning:

I’m using HA 0.85.1

Regards


#1724

please show your yaml as codeblock, as stated above every forum.
because this way we cant see where you go wrong.

but my biggest guess is that you used the wrong quotes
and i think host is obsolete


#1725

Sorry, I forgot to do it:

media_player:
  - platform: alexa
    email: "[email protected]"
    password: "SuperSecretPassword"
    url: "amazon.es"

I don’t think is the host, as I tried with and without, and I don’t think the problem are the quotes either, if I choose amazon.com instead, it didn’t fail… but it request me a captcha.

Is anything special required to be configured in my Amazon account? Is a new account, I’ve checked the password, and I don’t have two step authentication nor mobile phone setup.

Regards


#1726

then you probably didnt delete the cookie file and that has still the amazon.com connection it it.
alexa_media.pickle in your config dir should be deleted
then restart HA with the settings you have posted here last.

and if you have a phone with at least android 5 on it, i advise to install the app, because you can do a lot more in the app then in the browser version. (routines for example)


#1727

That did it!!

I thought that removing pycache folder inside media_player I was also deleting the cookie, but I didn’t realize about that file.

I’m using now the browser because it’s easier to configure the Echos with the laptop, but I also have the app and I love routines :smiley:

Thanks a lot for the help!! Much appreciated!

Regards


#1728

I’m getting the following error when testing the alexa media player:

Error handling message: {‘type’: ‘call_service’, ‘domain’: ‘media_player’, ‘service’: ‘alexa_tts’, ‘service_data’: {‘message’: ‘Alarm Armed’}, ‘id’: 26}
10:03 PM custom_components/media_player/alexa.py (ERROR)


#1729

what did you use to test your media player? code? service call?

you need to post details.


#1730

i dont see an entity ID in that service call


#1731

yeah sorry service call:

service: media_player.alexa_tts
service data: {“message”:“alarm armed”}


#1732

service: media_player.alexa_tts
service data: {“message”:“alarm armed”,“entityID”:“media_player.your_echo_name”}