Echo Dot integration


so I have the Docker setup behind a reverse proxy with SSL. And I bought the Echo Dot v3 because I thought I could simply integrate it.

I have followed this guide to integrate it:

But at the last step when I have to login via the Alexa App Dev Skill I only get an error like:

Link to X could not be made this time

And since I’m in the EU it wants to auth from

Can anyone point me in the right direction? Or is there any -simple- alternative?


emulated hue is a bit easier but much more limited in functionality. Also, you may need a gen 1 or gen 2 echo dot (I can’t confirm that because I don’t have a gen 3, it’s just a rumor I’ve heard on the forums).

Yeah Hue is not an option, I thought once about it and checked it out but it looks like even if I wanted it needs port 80 and as said I’m behind a reverse-proxy.

This doesn’t Look like it does what I want?

what about haaska i have been using that and very happy with it once it was all set up

It does not, it makes a media_player and you can push TTS to alexa. It does nothing the other way around.

He’s attempting to set up haaska from the looks of it.

Yeah I don’t want to use it yet as a media player… maybe later, no idea for that yet. Looks like my morning routine isn’t working as of now.

Oh looks like I need this then? You’re also using the Alexa Smart Home Skill which I linked? And this is just a bridge then in another docker container?

I will check it out, thx.

I set up haaska recently and was bashing my head against a wall for a while trying to get it up and running - same symptoms as you - in the end I figured out amazon was rejecting my letsencrypt certificate no matter what combination of settings i tried so i moved everything in front of cloudflare (which is an awesome thing to do anyway because it gives you all kinds of other benefits)

i have been using haaska with a letsencrypt certificate for months again was a bit of a mare to set up but works great for me once done. just because i’m to cheap to pay for the homeassistant cloud though

So I have worked through steps 1-4 while I mostly was able to reuse what I had from the other guide, just totally different data. However part 4 “testing” worked altough that part already worked for the other way also.

Now I was able to activate the skill and link accounts. But when it asks me to search for devices it finds 0. Anything I missed? How do I use it from here?

EDIT: Ok now back on Home screen it tells me it found 6 devices. But that ain’t all I need. How can I proceed from here?

using haaska i set it up to exclude all items then only exposed the items i wanted alexa to control

     - light.aurora_fwbulb02uk_02c28a06_1
     - light.ikea_of_sweden_tradfri_bulb_e14_ws_opal_400lm_fe224b1b_1
        name: Small lamp
        name: Nursery

That sounds good, but in my case it ain’t lamps that are missing. It detects all Lights and Switches.

I just want it also to turn on/off the TV, Nvidia Shield, FireTV. Maybe even start the Xiaomi Roborock. And even more awesome would be to ask "Alexa, what is the living room temperature? Alexa, how is the air condition? And generally asking for sensor data…

Additionally to that I have to find out how it would automatically pause Automations then.

i have a broad link ir device and i expose as well and i can get alexa to turn my tv on/off
here is some examples from my setup:

      - switch.tv_test
      - switch.tv_test1
      - media_player.nuc  
        name: Downstairs
        display_categories: TV
        name: Upstairs
        display_categories: TV
        name: Media
        display_categories: SPEAKER

i have not tried to expose sensors to alexa but i recon it should be possible

Ok, I found out that I already had there something preconfigured from earlier. But thx for the hint I edited it a bit:

      - vacuum.roborock
      - fan
      - light
      - media_player
      - script
      - sensor
      - switch
      name: Luftreiniger
      display_categories: OTHER
      name: FireTV
      display_categories: TV
      name: TV
      display_categories: TV
      name: Shield
      display_categories: TV
      name: Roborock
      display_categories: OTHER
      name: Bett Lampe
      display_categories: LIGHT
      name: Feinstaub
      name: Wohnzimmer Luftfeuchtigkeit
      name: Wohnzimmer Temperatur
      name: Schlafzimmer Luftfeuchtigkeit
      name: Schlafzimmer Temperatur
      name: Download
      name: Ping
      name: Upload

The problem I have there is, vacuum doesn’t seem to be supported. So I can’t add it at all or is it somehow custom possible?

The other thing is, it detects these 2 sensors:

  name: Wohnzimmer Temperatur
  name: Schlafzimmer Temperatur

But none of the others. What is this about?

expose what you want from the vacuum as sensor, switch, or light templates. Not every domain is available for all components, so you have to finagle it over.

I will check that out, thanks. But anyway, how is it that it only detects one sensor while there are multiple defined for the same device?

its possible that some sensor domains are not compatible. If hasska doesn’t have canned responses for a specific sensor type, chances are, it’ll ignore it.