Echo not showing devices in Routines

I have an Echo dot connected to my HA via the Emulated Hue. All the devices show up on my Echo in the smart home device list, but when I go to routines only a few show up in there. I have to use the all lights or all switches options as the only to do anything with these lights in routines.

I understand this this may not be the right place for this, but I reached out to Amazon with no response. Also I know a bunch of people on here use these devices and maybe someone has dealt with this before.

I am having the same issue, so if anyone has a fix / link /ideas to resolve this – please post it