ECO-DIM.05 dual dimmer not supported in ZHA?

I installed this dimmer because it should be confirmed to work in ZHA:

EcoDim LED Dimmer Duo 2x 0-100W ECO-DIM.05 Zigbee compatibility (

Manually everything works fine but when I try to control it from HA:

  • switching on/off: light turns on/off several times and get Failed to call service light/turn_on. Failed to send request: device did not respond
  • dimming does not work at all edit: was trying to dim using the slider in ZHA… does work from a Lovelace card

Reinstalled device several times, no difference.
Tried to reconfigure but this fails:

Changed some options but also no difference:

Has anyone managed to get this device fully working? I’m using a Sonoff Zigbee Dongle Plus-E with stock firmware.

I have exactly the same problem with the Skyconnect stick. Help is appreciated!

Sometimes the light will go on/off several times and then go to the correct state. Sometimes it will switch to the correct state at once but I always get this message:

@Stroo: if you have exactly the same problem with the Skyconnect the problem doesn’t seem to be related to the dongle.

LQI is 150 so that shouldn’t be a problem.

Indeed. Also have a good connection here. If you switch it on and off, it is repeated several times. It looks like ZHA retries a few times before giving up and returning the timed out error.

Is there a way to debug the communication?

You could try posting a device support request on GitHub.

@Stiltjack I did, ref [Device Support Request] Ecodim 05 · Issue #2865 · zigpy/zha-device-handlers · GitHub and received feedback that it does work for others without a quirk. Ecodim support told me both channels need to be a lamp (which is not the case for me). Might this also be the case for you?

Same problem here. Conbee II with a bunch of other Zigbee devices that don’t have issues. LQI and other metrics are normal. Ecodim DIM.0.7 works perfectly fine, but the DIM.05 dual has exactly the same issues.

In my case, lamps are connected to both channels. Just curious @Stroo, if you don’t have lamps on both channels, what do you have connected to it?

Both channels are connected to a lamp but I still have this issue.

I also contacted EcoDim support. Their feedback is that Home Assistant is not officially supported but that their engineers might have a look at it to see if there’s a solution.

Same issue here! Dimming works fine. No strange behavior. The problem starts when switching the lights on and off. ZHA reports: “Failed to send request: device did not respond”.

Haven’t tried Zigbee2MQTT.

Also, I cannot find any other Zigbee dual dimmer so i would really like to get this working :wink:

Work around is using automations to set brightness to 100% and 0%. Triggering these automations do turn on and off the lights, but when dimming to 0% (thus turning off the lights) the status in HA is off sync (keeps reporting on on the last know brightness level).