Ecobee 3 auto mode

I feel like this may be something simple but I can’t seem to figure it out.

In the ecobee doc’s it says that when the thermostat is in auto mode it will show two sliders to change the high and low temperature values and just a single temperature selector when not on auto mode, problem being is I can’t see the two sliders just the single selector when the thermostat is in auto mode.

Currently running home assistant version 0.53.1

I’m interested in this as well - the radio thermostats have an auto mode that doesn’t really work in HA because it can only set one temperature and picks whichever mode (heat/cool) is active at the time. It really needs a slider to handle this as well.

Looking at the source on github for the polymer front end (HERE) - it does this:

 computeHideTempRangeSlider: function (stateObj) {
    return !stateObj.attributes.target_temp_low &&

So it looks like the thermostat objects need ‘target_temp_high’ and ‘target_temp_low’ defined as attributes. Searching through the climate code (HERE), the only one I see that implements that is wink ( It doesn’t seem that complicated, but I don’t have an ecobee to test with.

I’m in the process of updating the radio thermostat code but I’m swamped this week with my normal job. When I get to it in the next couple of weeks, I can take a crack at updating the ecobee module as well and sending it to you to test if you want. It looks like those two fields just need to be added to device_state_attributes() method in (copy the style from

I’m happy to test anything. Living in Canada auto mode is a must for me since the temperature is so volatile having a temperature range is much more economical while keeping everything at a comfortable temperature at the same time. Looking at the attributes on the ecobee ‘target_temp_high’ and ‘target_temp_low’ are currently defined if that helps.

Well… It looks like the function I referenced above isn’t used anywhere. I tracked it back to these two pull requests which seem to say it should work but I can’t seem to get it to display the slider - it still just shows a single temperature. The second one even says “ecobee” as if that were done. I tried adding the low/high attributes to radiotherm (which I have to test with) and it changes the main card to show low->high but the more info card that shows the controls doesn’t change. I though maybe it had to be in auto mode but I tried setting that and it still just showed 1 temp control. It also seems like there is a bug in the main card - if I add the low/high attrs, it shows a temp range even if it’s not in auto mode. The code looks like it’s there, but it doens’t seem to be working.

Original issue:
Pull requests:

I’ll have to dig around some more and try and figure this out.

Solved in 0.63.

1 Like