Ecobee - No Target Temperature after 0.62 Update


I noticed that after updating to 0.62 around 6 AM this morning I am no longer able to see or set the temperature on my Ecobee device:

After noticing this I checked the attributes of climate.main_house and noticed that temperature is showing null and the target_temp_high and target_temp_low attributes are missing:

  "current_temperature": 72,
  "min_temp": 45,
  "max_temp": 95,
  "temperature": null,
  "operation_mode": "auto",
  "operation_list": [
  "hold_mode": "smart2",
  "away_mode": "off",
  "actual_humidity": 57,
  "fan": "on",
  "mode": "Home",
  "operation": "fan",
  "climate_list": [
    "Home Weekend",
    "Home Cold",
    "Sleep Cold",
    "Sleep Freeze"
  "fan_min_on_time": 20,
  "unit_of_measurement": "°F",
  "friendly_name": "Main House",
  "supported_features": 1457

Is anyone else seeing this behavior?



I’m having the same issue with the Auto setting. Looks like Heat and Cool modes still have target temperatures available.

1 Like

Thanks for opening the issue on GitHub!

This issue just started a couple of days ago when I turned the ecobee ‘off’ for a few hours via the thermostat card. Now, the temperature and target temps are showing null…has anyone ever encountered this?