Ecolink Door/Window Sensors DWZWAVE25 not working

I’m using ZWaveJS2MQTT. I have a bunch of these devices. I can learn them. The Control Panel shows “complete”. Then they become non-responsive, then fail. I used “remove failed nodes” and they were all removed. I tried to relearn/wake them, but it did not help. Is there something else I should be doing?

I have the same sensor and it works perfectly for me using the ZWaveJS Addon. I had to ‘wake’ it up physically by removing the battery door and replacing it. Not sure if you tried that yet?

Yep, I have! I still have three that didn’t get deleted and APPEAR to still be working (show “Completed”, show all the entities, etc)… But the doors have been opened, and they have no history. I really need these to work and I don’t know what to do.

I had issues with the Ecolink Door/Window sensors a few months back when I did a rebuild of HA. I had to reset the sensors and then securely add them to get them to work. Just putting the controller in normal inclusion mode did not work for me. Here are the steps I followed.

  1. Put controller in exclusion mode
  2. Remove battery from sensor for at least 5 seconds
  3. With controller still in exclusion mode re-insert battery into sensor (LED will blink slowly)
  4. Put controller in secure inclusion mode, not just inclusion mode.

And here is a FAQ document from EcoLink that I referenced during the process.

1 Like

So here’s what I did (I didn’t see the above post!) earlier this afternoon.
I excluded all of my sensors (I counted - I’ve got 15!).
Then one by one I included each sensor (standard, not secure) and woke it until “complete” was there.
But I noticed that they didn’t always work. THEN I realized - there were FIVE “disabled” entities. I enabled them - and then each would work, and they still do (I’ve been going around checking like a paranoid idiot).
If I have any future problems, I’ll try secure inclusion.

This worked!! The linked document is the key. Read it, and even if you think you’ve already excluded the device, if you are not successful getting an inclusion to work, follow the instructions regarding putting the hub in exclude mode and removing the battery, reinserting after 5 seconds, until you see the slow flashing led. If you are only getting a solid led, it will not include. You need to complete an exclusion, even if you think you already did. @jbv Thank you so much for sharing that link!!!

1 Like