Ecowitt weather station integration issue

So I updated home assistant and was greeted by this after the ecowitt integration failed to load :frowning:
I manually added some version thing to the previous version because home assistant wouldn’t boot otherwise.

Logger: homeassistant.setup
First occurred: 11:31:02 PM (1 occurrences)
Last logged: 11:31:02 PM

Setup failed for ecowitt: Unable to import component: cannot import name ‘VOLT’ from ‘homeassistant.const’ (/usr/src/homeassistant/homeassistant/

What does this mean and how does one fix it exactly…

Same issue here. I suspect the custom component has been broken by something in the update to HA…

Same thing here…Looking at it now, anyone ideas?

See GitHub

Solve my issue with Ecowitt and 2021.8 :grinning:

1 Like

works for me! tnx

Worked for me too.

Is this going to be fixed it something? How many references of volt do I have to change to ELECTRIC_POTENTIAL_VOLT
And is this caused by the update?

through you. :grinning:



I mean has anyone like started a thing on GitHub to let the person that made it know theirs an issue caused by the update? The problem thing

The issue was already reported. Pull request is done.
But it looks like the developer is out off office?!
Last update was 5 month ago?

Oh ok. Well then.

not for me :sob:

Pardon? You mean the solutions provided aren’t solving the issue?

maybe is my homeassistant, i have Ecowitt Weather Station in hacs, but in configuration/integration + new integration, cant found ecowit after upgrade home assistant

Yes that’s because of one of two things. Of you updated ecowitt then you need to change the manifest.json. you need to add a version. If you upgraded home assistant you need to replace the references to volt with, whatever I said a few posts back on this question here. Also if you don’t know why you need to look at the logs. And then click load all logs or whatever it says at the bottom to see what the issue is. If it says something about a version in relation to ecowitt you need to cha get the version thing. If it says something about volt you need to change 12 references to the word volt to, umm, this “ELECTRIC_POTENTIAL_VOLT” because of something that was updated in home assistant. Look at your logs.

yes, after back snapshot, and changed, works, thanks

Cool beans and tacos. Glad it’s working.

beans, tacos and peperoncini calabrese…

I’ve updated to version 0.7 and all references are already named ELECTRIC_POTENTIAL_VOLT. The version is also included in the manifest. What do I miss?