ECOWITT Weatherstation integration for Home Assistant

I am trying to get this integration going but not quite sure how.

I have followed the setup guide as best I can but not sure what I am doing wrong when adding the config to my configuration.yaml file as keep getting invalid config integration not found when I check my configuration.
This is my setup on my ECOWITT HP2551
From the HOW to Setup Guide…
Pick the protocol Ecowitt, and put in the ip/hostname of your hass server. Path doesn’t matter, pick the default. Pick a port that is not in use on the server (netstat -lt). (4199 is probably a good default) Pick a reasonable value for updates, like 60 seconds. Save configuration. The Ecowitt should then start attempting to send data to your server.

I actually configured this on my display using the keys at the bottom of the pic.

The code below is supposed to be added to configuration.yaml but no matter what I have tried it, it does not seem to be correct. I keep getting a message that the integration ecowitt does not exist???

  port: 4199
  barounit: metric
  windunit: imperial
  rainunit: imperial
  windchillunit: hybrid

Anyone got any ideas on where I am going wrong?

I have this HP2551 unit reporting to Weatherunderground and but was wanting to grab a few things off it for my HA automations.
This is what is on from my uploads.

1 Like


Before you can add the configuration.yaml you need to install the add on first as it is a community add on.
The easiest way to do the install is to install HACS first. from there you can find and install the ecowitt integration, and then you can add the lines to configuration.yaml.

Also be aware that home assistant will not boot until it receives information from your weather station. This is only because it is a work in progress.

Thank you. Welcome to the forum.

I had found out that I needed HACS but the bit about HA not booting until it receives data from the weather station was a show stopper for me.
However I did read that HA version 111.0 goes some way to fixing this. I have updated to 111.0 but will wait until I see if it fixes it.

Cut and paste from BLOG
However, with this change, Home Assistant no longer waits for all integrations to be ready. As a result, not all devices and entities are available immediately.

This is actually good! As this means, an integration that got into trouble, can no longer prevent the frontend from becoming available. Also, as soon as it is available, you can change or remove the configuration of a non-working integration. Finally, it easier to check out your logs when something goes wrong.

Hi Ron, I have the an Ecowitt station as well.
Did you end up having success with the HACS addon and HA as described ?

Hi Mr Sneezy,

Sorry I have not got back to it as yet. Too many other pots on the boil.
I will post if I do.

Finally found the time to have a play with this.

I had previously set up my ECOWITT display to export data to my NUC using the advise contained in the documentation and enabled it so it had been doing this for some time.

I followed the advice of Tim Rightnour’s email and just copied the Ecowitt code by itself rather than install the full HACS.
I have pasted the relevant parts of his email below.

"If you want to try without, checkout the git tree of this repo, and copy custom_components/ecowitt to your .homeassistant directory, so you have:

Then restart, and you should see some kind of messages saying it is attempting to start in the logs."

I added this to my configuration.yaml

# Ecowitt
  port: 4199
  barounit: metric
  windunit: metric
  rainunit: metric

I save the file and checked my config and it told me that the config was invalid because it could not find the Ecowitt. I thought that was probably true because it had not yet seen the custom components so I commented out the lines, restarted, un-commented and rechecked. Now it was valid.
I now restarted.
I am running 112.2 and restarts on my NUC are very fast.
Below is an image of my quick Entities panel to prove valid data.


The data was valid so I am assuming all good so far.

Hope this helps.

I have just moved over to using HACS rather than manually installing ECOWITT.
This was because it was just too cumbersome to do any updates and bug fixed to the code from Github. HACS handles all this for us/me according to what I read in doco on HACS.

I’m thinking of buying an Ecowitt GW1000 (or Froggit DP1500 as the European version seems to be called) together with one of the ‘all-in-one’ outdoor sensors. I would like to upload the data to both my home assistant using the custom integration and Wunderground. Does anybody know if the GW1000 can upload the data to both the Home Assistant and Wunderground at the same time? According to the documentation I can find online it can upload to Wunderground and Home Assistant, but I cannot find if it can do both at the same time. Topic starter at least suggest that his unit uploads to 2 services simultaneously: “I have this HP2551 unit reporting to Weatherunderground and”.

Hello Dick,
I started this topic.
I am not sure what the Ecowitt GW1000 is. I tried looking for it on the ECOWITT site but in my brief look the 1000 series seems to want to use a mobile phone as it’s display.

As I said, I use the HP2551 ( which comes with a separate color display and I now can upload to up to three sites. I do use all three and upload to WU, Ecowitt and HA concurrently. Two destinations are activated but the third needed to be enabled but that’s just a check of a box.

My personal opinion…
I have had two units (different brands, ECOWITT being the latest) in my time of using PWS’s. One without a display and one with. I definitely like the one with a display as the display is much more than just a display. It’s more like a weather hub for many devices. I run the outdoor unit which does rain, temp, humidity, wind etc., an indoor unit for temp and humidity, an air quality unit. It can also do a number of others if I wanted to.
I think that the HP2551 is far superior to the earlier one I had and suits my personal needs much better.

You could always email Ecowitt on their contact page and ask them direct.

1 Like

Hi all, this integration is great. Worked straight away with the GW1000 + a range of sensors and its great that we can still upload to the ecowitt server as well as HA. Just one question does anyone else use the soil moisture wh51? The reporting on this seems quite erratic, reporting really frequently sometimes and then going 24 hours before updating the value value other times. Any one else have similar or different experience ?

See my previous post. I’ll check WU tonight.


can confirm you can upload to HA, weather underground and ecowitt all at the same time from the gw1000


Hi, I just got the same weather station GW1002. Could you give me a step by step as to how you added in your integration?

Thank you!

Sorry for the slow reply,

I added

port: 4199
barounit: metric
windunit: metric
rainunit: metric

to the config and then added customized server to the weather services with type - ecowitt, ip address of home assistant, path - /data/report , port 4199 and upload interval 60

1 Like

PS there is a known issue with this integration and 0.115 so if you upgrade you wont be able to get it set up right now.

1 Like

It’s working for me at the moment on 114. Thanks for the heads up.
The one thing not working is weather underground for some reason

Hmmm, mine is still working just have my station id and key that i got when i registered at WU. These are the ones visbile when you login to your account and look at devices.

Do you remember how you set it up in home assistant? I cannot get my pws entity to work properly somehow

Is this still an issue with 0.116? I just got the ecowitt gw1000 and was looking to get it setup.

The other thing that concerns me is that if the ecowitt is offline (for whatever reason) when HA restarts, it will crash the HA boot up process? That kind of stopped me cold in my tracks…

It hasn’t been fixed in HACS, but I made a fix and a PR, but the owner of the repo hasn’t approved it yet.
You can grab the updated code from here:

I haven’t tried the reboot as you are asking, but I believe that is only the case at the first start-up of the integration.