ECOWITT Weatherstation integration for Home Assistant

I am trying to get this integration going but not quite sure how.


I have followed the setup guide as best I can but not sure what I am doing wrong when adding the config to my configuration.yaml file as keep getting invalid config integration not found when I check my configuration.
image
This is my setup on my ECOWITT HP2551
From the HOW to Setup Guide…
Pick the protocol Ecowitt, and put in the ip/hostname of your hass server. Path doesn’t matter, pick the default. Pick a port that is not in use on the server (netstat -lt). (4199 is probably a good default) Pick a reasonable value for updates, like 60 seconds. Save configuration. The Ecowitt should then start attempting to send data to your server.

I actually configured this on my display using the keys at the bottom of the pic.


The code below is supposed to be added to configuration.yaml but no matter what I have tried it, it does not seem to be correct. I keep getting a message that the integration ecowitt does not exist???

ecowitt:
  port: 4199
  barounit: metric
  windunit: imperial
  rainunit: imperial
  windchillunit: hybrid

Anyone got any ideas on where I am going wrong?

I have this HP2551 unit reporting to Weatherunderground and Ecowitt.net but was wanting to grab a few things off it for my HA automations.
This is what is on ecowitt.net from my uploads.

Hi

Before you can add the configuration.yaml you need to install the add on first as it is a community add on.
The easiest way to do the install is to install HACS first. https://hacs.xyz/. from there you can find and install the ecowitt integration, and then you can add the lines to configuration.yaml.

Also be aware that home assistant will not boot until it receives information from your weather station. This is only because it is a work in progress.

Thank you. Welcome to the forum.

I had found out that I needed HACS but the bit about HA not booting until it receives data from the weather station was a show stopper for me.
However I did read that HA version 111.0 goes some way to fixing this. I have updated to 111.0 but will wait until I see if it fixes it.

Cut and paste from BLOG
However, with this change, Home Assistant no longer waits for all integrations to be ready. As a result, not all devices and entities are available immediately.

This is actually good! As this means, an integration that got into trouble, can no longer prevent the frontend from becoming available. Also, as soon as it is available, you can change or remove the configuration of a non-working integration. Finally, it easier to check out your logs when something goes wrong.

Hi Ron, I have the an Ecowitt station as well.
Did you end up having success with the HACS addon and HA as described ?

Hi Mr Sneezy,

Sorry I have not got back to it as yet. Too many other pots on the boil.
I will post if I do.
Cheers

Hi,
Finally found the time to have a play with this.

I had previously set up my ECOWITT display to export data to my NUC using the advise contained in the documentation and enabled it so it had been doing this for some time.

I followed the advice of Tim Rightnour’s email and just copied the Ecowitt code by itself rather than install the full HACS.
I have pasted the relevant parts of his email below.

"If you want to try without, checkout the git tree of this repo, and copy custom_components/ecowitt to your .homeassistant directory, so you have:
.homeassistant/custom_components/ecowitt

Then restart, and you should see some kind of messages saying it is attempting to start in the logs."

I added this to my configuration.yaml

# Ecowitt
ecowitt:
  port: 4199
  barounit: metric
  windunit: metric
  rainunit: metric

I save the file and checked my config and it told me that the config was invalid because it could not find the Ecowitt. I thought that was probably true because it had not yet seen the custom components so I commented out the lines, restarted, un-commented and rechecked. Now it was valid.
I now restarted.
I am running 112.2 and restarts on my NUC are very fast.
Below is an image of my quick Entities panel to prove valid data.

image

The data was valid so I am assuming all good so far.

Hope this helps.

I have just moved over to using HACS rather than manually installing ECOWITT.
This was because it was just too cumbersome to do any updates and bug fixed to the code from Github. HACS handles all this for us/me according to what I read in doco on HACS.