Edge browser hanging

Hi, I am trying to see if I am the only one experiencing this and posisbly point to the source. When opening HA in Edge it is sluggish a bit and when clicking 2-3 times in the left menu it hangs. Chrome does not have this but Edge was working fine for 2+y.
My win10 got an update yesterday and I believe this could be the cause.
Other sites with Edge seem fine (fafaik now)
Anyone else seeing similar?


Yep, I’m having the same issue

Yes! Me too.

I tried it from 3 different PC’s (all Windows 10 that was updated yesterday), to 2 different HA sites.

Chrome seems fine as does the Android app.

I was just about the make a topic, glad I’m not the only one. I’ve tried so many things already.
It works locally just fine via IP-address, but externally (domain via NGINX and Cloudflare) keeps freezing after a second. Tried multiple devices. On my Android phone it all works, but Windows devices with Edge are freezing. Tried to clear caches everywhere, rebooting, etc.

Please don’t reply to the issue with “me too”. Unless you have new data to add, just :+1: the first post to show that you too have the issue.

The issue is caused by Bitwarden most likely. Disable it or disable its autofill and the problem is gone.


Can confirm that it is Bitwarden … with Chrome I did not have it activated but after doing so, also Chrome started to display the same issue.
However, the freezing seems to only be with HA… I just browsed about 15 sites without issues

EDIT: no it is not just with HA … using a temp workaround and set the extension to ‘on click’


I see that Bitwarden released its new extension version (v2024.6.0) just the day before yesterday (June 12th).

On another computer with still v2024.4.2 I don’t have the issue.

There is a topic on Bitwarden community forum handling the same issue: Bitwarden Chrome extension update causes Home Assistant website to hang - Password Manager - Bitwarden Community Forums

And a related GitHub issue: macos 2024.6.0 some websites stalls if extension is active · Issue #9617 · bitwarden/clients · GitHub


Chrome browser also hangs with Bitwarden. I’ve transitioned to Firefox which works fine.

Bitwarden was updated this morning and the problem has now been resolved!

1 Like