Eero Support


#21

If we get this squared away and working well, then I can work towards a full integration. The initial session creation is problematic, although I could make a website to do that for the end user.

I just made changes for the python3 problem, so it should be backwards compatible with python 2 as well. I put it up as 1.0.1.


#22

You should be able to follow the readme file on the github. There’s a line in there about how to run it :slight_smile:


#23

Alright – more updates with new enhancements, yay. New version: 1.0.2

Added:

  • Account caching. So instead of two requests every device poll it’ll be one request. It’ll refresh every hour
  • Device nicknames. If you set a device nickname in the Eero app, it’ll map through as the device name.

Fixes:

  • Error handling bug…some code in there would’ve thrown errors since it was referencing undefined vars.
  • Worked a bit on improving the python conventions.

For those that need to update. Just overlay the scripts. Keep your eero.session file, there’s no need to remove it and re-initialize.

Link to the project again…the zip is under the releases tab: https://github.com/jrlucier/eero_tracker


#24

Yeap. Sorry I missed that. It is working. Thank you for this work!!


#25

Still trying to get this device tracker added to my setup (latest HA via Docker on Synology), but getting an error with Configuration validation - “Platform not found: device_tracker.eero_tracker”.

I SSH-ed into the docker container to run the necessary commands outlined in the readme, and even got the “Login successful. eero.session created, you can now use the device_tracker.” Also have tried restarting HA, but the configuration validation continues to fail.

Any ideas or suggestions for what might be missing in this type of setup?


#26

Where have you placed the eero_tracker.py python file? Also what does the log look like when you restart HA (required to see the new python file)?


#27

ahhh, that’s it! Wasn’t clear on where to place the file due to my config, but I see now that it says to put it in the “configuration directory.” I had it one level higher than that, so after moving, checking config, and restarting, it’s working as expected. Thanks. Glad to see it works in my config!


#28

Does this allow you to reboot the eero? I’m having some issues where I can’t browse internal websites using hassio.example.com (every service actually). I’d like to write an automation that will reboot the network if this issue arises.


#29

Any instructions on how to set this up?


#30

The code in the github has a readme with the instructions on setting it up. It should be fairly easy to follow. That said all it adds is device tracking for your Eero within HA – since that was the only thing I was really interested in.

Should you want to expose other Eero functionality (like restarting), you’ll have to write up the code to do so. If you look at 343max’s code, there are hooks that you could utilize to do so.


#31

What is device tracking? Inside your home? Is that accurate?


#32

This code is working GREAT! I can see all of my Wi-Fi connected devices on my eero system, but I seem to recall that this release will not track the hardwired devices, right?


#33

Glad to hear it! I filter out the hardwired devices and only include wireless ones. Perhaps I’ll add that as an option? You can remove half of an if-statement in the python if you want to do it right now. :wink:


#34

It tracks what devices are on your network. So if I arrive outside my house my phone automatically will connect to the eero and my HA will notice and unlock my front door. It’s more accurate than GPS and there’s no odd flukes other methods have


#35

I’ll take a look at the python code - can you give me a hint where it is?

I may have to as I have 2 x 8 port hubs that have all my Multimedia Devices connected to them - would be nice for presence detection as if my Media Center computers go down or power off - I would like to initiate a WOL or Power up remotely to get them working while I am away. With 70+ Wireless devices in the home, taking 16 off the Wi-Fi isn’t much of a dent in the Wireless radiation, but my streaming is unaffected by close range speakers and routers…

Thanks!


#36

Ah, I was goi g to do that. But I live in a walkable neighborhood, so I’m just as likely to be walking home as driving home


#37

Is this still working? I am unable to login. The script errors right after I give it my phone number and never creates the session file.


#38

I’ll check when I get home…the latest updates might have broken stuff :wink:


#39

Looks like there might be API changes that need reverse engineering. For those using the already existing tokens, everything is fine. For someone registering a new one, eh…some work needs to be done.

@343max — Can you sanity check me?


#40

Hey! It was a bug on my side and the API isn’t as forgiving anymore as it used to be. I just pushed a fix.