Eero Support

Thanks for the quick fix @343max ! I’ve pushed an update to the device tracker for Home Assistant to mimic the changes. @cjs28 give it a try again :slight_smile:

No one that has it already integrated needs to update. It’s only for those who are just adding it fresh or needing a new session token.

Thanks @343max and @Scythe for the quick turn around. The new fix worked perfectly, and I have this up and running.

I am added this as device tracker and I am noticing it jump between home and away, while I am sitting here at home. Is there anything I can do to stablize this? I tried to adjust the time is checks the api by changing the value from 60 to 120 but it did not seem to make a difference. Anything else I can try?

@Scythe

What is your consider_home set to? Can’t say I’ve had similar issues :confused:

So my consider_home in my configuration.yaml file is set to 300. I have tried to increase and decrease that value and it really did not seem to matter what I set it at, the device tracker would flip from home to away.

Configuration.yaml:
# eero device tracker
- platform: eero_tracker
consider_home: 300
interval_seconds: 60

I did some digging and I noticed you can override the value for consider_home by setting it in the known_devices.yaml and that seems to be working. When connected to WIFI, it stays on home now instead of flipping back and forth.

known_devices.yaml
android:
hide_if_away: false
icon:
mac: ##:##:##:##:##:##
name: Android
picture:
consider_home: 300
track: true

Thanks for your help!

@Scythe

So, I’m having some trouble setting this up. I’ve followed all the instructions and was able to get a token and that all seems fine. But when I set up a tracker, it doesn’t seem to be seeing the eero info. I’m pretty new as HA in general, so I could be setting it up completely wrong. Please help.

I have a known_devices.yaml file which was the devices I want to track, but when I view the state of the devices, I just get source_type: null for them.

Any ideas?

Any luck @flippedcracker? Sorry, I just saw this in my inbox :slight_smile:

No luck. I did figure out in the log that HA wants /device_tracker/eero_tracker.py to actually be /eero_tracker/device_tracker.py. But that didn’t fix it. I’m sure it’s something basic that I’m missing. I’m running HA in a docker on unraid if that means anything.

Mine is working fine after slight modifications that had to be made for changes in HASS.IO 0.91, where I had to create a /config/custom_components folder and an eero_tracker folder under it and move the device_tracker.py file into it.

1.  The eero.session file remains in the root of /config
2.  device_tracker.py file is in /config/custom_components/eero_tracker
3.  eero_tracker.cpython-36.pyc & 37 and device_tracker.cpython-37.pyc files are in /config/custom_components/eero_tracker/__pycache__

My configuration.yaml contains the following:

device_tracker:
  - platform: eero_tracker
    consider_home: 240
    interval_seconds: 300

See: https://developers.home-assistant.io/blog/2019/02/19/the-great-migration.html

Thanks.

Thanks for the info Bsheedy – I’ll work to backport those changes into the github. I did create an issue in the tracker for the big rename that needs to happen.

@Scythe I’m still trying to work this out. I have noticed that re-running the eero_tracker_instantiate.py doesn’t populate the eero.session file with anything, other than the original login token. Maybe that has something to do with it? I’m not getting any errors, just not getting any information either.

Are you using python3 or 2?

Also updated the component to 1.0.4 – with the new custom_components structure thanks to a pull request. If you’re running the latest version of HA, upgrade the component so your integration won’t break with a future HA update.

Leave your eero.session and delete all the other eero_tracker files. Then just overwrite it with the latest zip and restart.

I’m using python3.

@Scythe
I’ve figured out my issue. I didn’t realize that my network was associated with a different phone number. Basic user error.

Awesome! Glad it’s been figured out :slight_smile:

I’m having trouble running automations with:

trigger:
    platform: state
    entity_id: device_tracker.xxxxx
    from: 'not_home'
    to: 'home'

The automation never triggers even though my status on the Overview changes perfectly.

If I disconnect from my Eero, though, my status does not reliably change unless I reboot the Pi. Any thoughts?

Hmm…can’t really help much there. That’s very much an HA core codebase thing. The eero device_tracker just tells HA the current state of the devices, as to how HA handles those states is up to the core software.

Sorry to switch topic. I tried to search info regarding using duckdns and letsencrypt in hassio addons using eero as router. Has anyone done it with success? If so, please point me the direction. Many thanks.

@Scythe first of all thanks again for building this, i’ve had it installed now for a year :slight_smile:

I just noticed the ‘Family Profiles’ in the app, with the ability to pause or schedule pause. I don’t suppose if you can see any of this in the API?
(I’ve had a play with the API, but not a dev :frowning: I cant work out how to auth using GET requests from the code, to see what options come back)

Would be cool to pause all guests or all kids WiFi via an automation (or button in lovelace :slight_smile:)