Elfin EW11 connection issue


I’m new to HA and I’m making some progress but while I’m keen to read and learn I’m no IT wizard. I have asked on the specific project but it’s not fair expecting a single project owner to explain what are probably obvious step. Like you need to set a static IP address. The project I’m working on is this:

I can connect to the EW11 as an AP to configure.But I can’t get to to connect to Wi-Fi and be visible as a device.
I don’t know my WAN from my LAN so I’m pretty sure I’m messing up that settings page as the instructions assume I know how to set up a static IP and configure WAN and LAN.
I found the operation manual so switched off DHCP and tried these settings. That didn’t get me very far do some of those settings probably need changed to match my router IP/gateway? I can add my Wi-Fi and password.

I won’t be insulted if someone wants to explain in simple terms what I need to do to set a static IP and configure for my network.
Thanks Richard

Use wifi mode STA only

Thanks I tried STA only. Any pointers on what WAN and LAN setting should be?

Hotspot mode

Wan - sta - client - wifi

Lan - ap - hotspot

I did a few hours googling.
I remembered some of these devices only work on 2.4GHz Wi-Fi not 5GHz. I’ll now use my 2.4 option but that hasn’t fixed it yet.
I’m pretty sure the LAN IP needs to be the AP IP for the EW11 so and think it’s mask would be
For the WAN if I switch off DHCP and manually enter I’ve tried various things and really have no idea what goes in the three fields. However with DHCP automatically picking the IP I figured it should work today so at least I could see if it connects.

If this works I’m expecting to see the EW11 as a connected device in which is my router IP when I connect back to Wi-Fi. So far it’s never appeared.

Any luck with this?


I’m struggling to see my Elfin EW11 on my guest network atm

Which WAN and LAN do I need to change to achieve this?

For anyone having difficulty with an ELFIN EW11 WIFI setup, I got some useful pointers from jumpy07 on GITHUB.

If you leave the WAN DCHP switch ON, then there is only one field in the WAN section to fill in; DNS. This is where your router IP address goes. This was key for me.

I found this counter-intuitive and had been leaving the DCHP switched OFF. This resulted in 5 fields in the WAN section which got me totally confused and I wasted a lot of time. I tried all sorts of combinations and the got various errors about IP addresses having to be on different sections in WAN and LAN ?!?

If you leave DHCP “ON” (as I was advised by Jumpy07) in the LAN section, this results in the EW11 ignoring what you enter in the LAN IP.
So, look in your router DHCP table to find it. My Virgin router had it listed as EW11 but you can use the MAC address too, in case you router doesn’t list names (it’s printed on the side of the device)

this is straightforward and you can scan for networks too. A nice feature.