Emulated Hue - Can't discover devices

I’ve configured HA (0.85.1) for emulated hue using following entry in my configuration.yaml. (I have no physical hue bridge or bulbs. HA and Echo are on the same LAN):

      expose_by_default: false
      listen_port: 8300
        - light
          name: "Lamp"
          hidden: false

If I browse to I see the output below which suggests that everything is configured correctly:

{"6": {"modelid": "HASS123", "name": "Lamp", "state": {"bri": 0, "on": false, "reachable": true}, "swversion": "123", "type": "Dimmable light", "uniqueid": "light.0x000b57fffe1606db_light"}}

The Problem is I can’t get Alexa to discovery the device. So far I’ve tried the following:

  1. Adding a Hue Device using the Alexa App on my Phone - no devices found
  2. Asking the 1st Gen Amazon Echo to discover devices - no devices found
  3. Tried switching to listening on port 80 instead of 8300 - no change
  4. Installed the Philips Hue skill in the Alexa app, but can’t enable it as it says ‘There are no Bridges on your network’. (I did wonder if this is only needed if you are using a real Hue Bridge)

Not sure where to go from here. Any assistance would be greatley appreciated.

I’ve the same problem.

Tried every thing you mentioned. Even tried Hass.io and Hassbian. Alexa just doesn’t find the devices !!!

how are you trying to discover the devices? You shouldn’t need any hue app, at all. You should just go to the smarthome section and hit discover. All the defaults should work as long as you are using the gen 1 echo.

Hi @petro, I have a 1st Gen Echo, not the do, and have tried discovey by voice request and using the Alexa app on my iPhone. I have not installed the Philips Hue app. The problem (I think) is that I can’t enable the Hue skill in Alexa, it fails saying ‘there are no bridges on your network’ and disables itself.

When you go into the app:

  1. Select devices
  2. Select all devices
  3. Select the plus in the upper left corner
  4. Select add device
  5. Scroll to Other, select other.
  6. Select discover devices.

Thanks for the prompt reply @petro. Tried that - No new devices found. Also tried switching the config from port 8300 to 80 with the same result.

you shouldn’t have to change the port. This is my config with a gen 1:

  host_ip: !secret emulated_hue_ip
  listen_port: 8300
    - script
    - scene
  expose_by_default: true
    - light
    - switch
    - input_boolean
    - fan

what happens when you go to

http://<HA IP Address>:8300/description.xml

I actually found selecting “Philips hue”, then selecting “Philips Hue V1 bridge (Circular shape)” worked for me, both for the Home Assistant HA Bridge and Node-Red node-red-contrib-alexa-local node.

That’s good to know, I haven’t actually done a re-discovery since the update to the alexa app (when it was only a single button).

Oh Gosh this is embarrasing. Just realised my Echo is on my guest LAN! Switch it to my main LAN and it’s now discovered the light. Thanks for your help guys!

1 Like

I had a similar issue with a similar solution however I’m not sure of the cause. I had set up hue emulation about a month ago and suddenly, 2 days ago Alexa could not communicate with the hue hub. Everything looked fine in hassio. Test urls (description and api/pi/lights) worked fine. Tried removing the hub from Alexa app (this was a bad idea as it broke the relationship between my hub and all my lights). Tried deleting the hue emulation json file (this was also a bad idea). Tried changing my IP reservation and updating configuration yaml to match. Tried upgrading home assistant, tried downgrading home assistant. Many tweaks to configuration yaml to no avail and eventually broke my hassio so badly that I decided to reinstall hassio from scratch (ugh!). STILL, Alexa could not discover it. I read this thread and finally had an idea. I could see my echo was on the right wifi network so I ran my echo (gen 1) through the setup process again to reconnect it to the same wifi network and it finally worked. I’m using Google WIFI Mesh. I’m not sure what happened but something was preventing Alexa from communicating with the hue emulator. Either an update to Alexa or to the Mesh possibly affected it or some weird NAT table entry got created. Regardless it needed a very swift kick to get it in a working state. So my new troubleshooting process:

step 1: test urls
step 2: run Alexa setup
step 3: reset wifi network - cycle power on all APs and switches
step 4: give up and set up Haaska

1 Like

Thank you for posting your findings, your solution worked for me! For anyone else that might stumble across this, I can confirm that redoing the network setup on my Echo through the Alexa app (to the same network as before) was the fix in my setup too.

I know this is an older thread, but I’m now running into a similar issue, I can’t get my Logitech Pop Bridge to find the emulator. I think however that it might be for a diffrent reason… I moved my HA to a new Pi 4 and moved it to hardwire network, I think my bridge is only scanning the WiFi. any ideas? or any possibility of the emulation being able to choose a connection type in config?

ok so here’s what I’ve figured out. Older Echos work with the emulated hue but newer ones do not. When I get into a bad state I disconnect all echos except the old gen 1 echo (full size) and that usually allows me to reestablish with the emulated hue. I think I also have to make a rule in my firewall to forward port 80 to the HASS.IO IP.