Emulated hue help


I am unable to get Alexa to discover any of my devices. I have set port to 80 and ran the
sudo setcap ‘cap_net_bind_service=+ep’ /srv/homeassistant/bin/python3.7

Command as well. Rebooted both the pi and Alexa’s. Removed power from my echo plus and tried discovery only via my dot V2 but still not discovering devices through the app or if I ask Alexa to discover.

Also if I go to -pi IP-/API/pi/lights I get a response with all my entities.I am running the latest version of HA(0.102.3) in a virtual environment on a rasp pi

Any help much appreciated

I have updated to the latest version of home assistant 0.103.0, I see there are fixes for the emulated hue component but i still cannot get this to work. my config is as follows:

  listen_port: 80

If i delete the emulated_hue_id.json file from my config folder… scan for new devices using “Philips hue > Hue hub v1” (there are no devices in the alexa app at all as i have deleted them) After about 1 minute the app comes back and says there are no new devices found. Although a new emulated_hue_id.json file appears with the list of all my entities… But alexa cant see them.

Still getting a response from http://ip/description.xml & http://ip/api/pi/lights

I am not really where to go with this from here