Enable BLE Transmitter via notification command don't work anymore


just installed the new beta to use the new feature of changing the transmit power and advertise mode of the ble transmitter (thanks a lot for that feature, it’s really cool). As this works as expected i now have problems to enable or disable the transmitter via the command. I’m using the command from the docs, but now i get a message instead of en/disabling it. Has the command changed also and the docs are outdated for that feature?

Command im using is:

service: notify.mobile_app_sm_g996b
  message: "command_ble_transmitter"
  title: "turn_on"

And the phone receives the readable message and nothing else…

Thanks Mike

Could you please open an issue here:

1 Like

please update to at least beta 2108 and if the issue still exists then yes please file an issue in the above link, this should be fixed by https://github.com/home-assistant/android/pull/2313 which is in the mentioned beta version.

Updated, and works again as before. Thanks to you and everyone else who worked on it for the fast fix.


1 Like

Hey I am using the latest android app i.e. 2022.3 and I have enabled my BLE Sensor on my app and have also granted all the permissions required including location. However my BLE is not advertised on my HA. I have restarted my phone as well but no luck.

Is there an issue with the android app? or am I missing something ?


Just tried, here it’s working (i am on beta-2218 but should work on 2022.3 also).
When you look in the bluetooth sensor, does the activate transmitter switch turn on and off when sending the command?

I am on beta-2478 and am having this issue now, that the command is just shown as message, but BLE does not get turned off or on. Is anybody else having issues with this?
Thank you!

Breaking change in latest beta also mentioned in the change log, refer to the beta notes here (4th example) for updated format:

1 Like

Read the docs, the yaml for intentions have changed.

1 Like

And since we are at it…
I have successfully changed all my notification commands according to the docs.
Those that I use worked fine.
I feared it would be much harder than it was.
The biggest issue was to find the automation that sent the notification.

1 Like

yea it was time we started to use variable that make sense instead of what was already white listed. Every time we add a new variable we have to whitelist it on FCM.

Thank you! I missed that.

1 Like

The error is there once again since the last app update.
I am getting a message instead of turning on or off the BLE transmitter.

Did you click on any of the links above?

Yeah it was actually a change that was only documented in the examples. Seems to work now.