Enable qemu-guest-agent with Synology VMM virtualization

Hi,

As an HassOS feature, I suggest to “Enable qemu-guest-agent with Synology VMM virtualization”

Synology VMM relies on qemu-guest-agent to communicate with HassOS VM.
On the VM side, systemd detects microsoft as the virtualization technology. Log extract shows: “systemd[1]: Detected virtualization microsoft.”
HassOS currently only enables qemu-guest-agent on qemu and kvm virtualization technology.

I am ready to PR the feature, but I would like to discuss wether adding microsoft virtualization technology is the good way to go.

Reference:
Latest qemu-guest-agent commit, adding “qemu” as supported virtualization

Mathieu.

That would be great actually! So I agree with you @mathieu-mp ! I think lot of us here who are on the Ubuntu or Debian on Synology VMM would like to see this feature before we switch to HassOS.

It would be great if this did work; however, systemd-detect-virt should not return “microsoft”, as it should only be for hyper-v hypervisors. So this seems like a Synology bug. (It does the same thing with an Ubuntu 20 image) I filed an issue and can report back if I get a response.

This is annoying based on the statements that the Synology VM approach is supported in lieu of fredrike’s native package.

1 Like

So a little more digging has indicated that if KVM or QEMU is run with Hyper-v Enlightenments it shows up as ‘microsoft’. So this seems to be a systemd or HassOS issue. Possibly systemd as it does do any additional probing after detecting that it is hyper v.

If anyone cares, or stumbles upon this in the future, an issue has been logged with systemd. https://github.com/systemd/systemd/issues/17894

Also Synology responded and the way to fix it is:

I did some testing and found that this issue is due to the option “Enable Hyper-V Enlightenments” found under DSM > Virtual Machine Manager > Virtual Machine > edit the VM in question > General > click the Gear button next to “CPU(s).”
NOTE: This option cannot be altered while the virtual machine is powered on. Please shut down the VM before editing it or the checkbox will be greyed out.

3 Likes