Enabling cloud component breaks Alexa component

Since 2022.2, all of my custom Alexa integrations have stopped working. The endpoint for the skills (using these instructions) is /alexa/api

Typically, if you try to visit that address in your browser (where the method would be a GET), you’ll get a 405 error. That’s normal as the API requires a POST.

But as of 2022.2, I get a 404 - the API is completely broken.

I’m running on Home Assistant OS. I’m also using the Nabu Casa Cloud integration, but cloud and the Alexa API have been peacefully coexisting until this month. The issue persisted with 2022.2.2 and 2022.2.3. I’m currently updating to 2022.2.5 to see if the issue has been fixed.

Anyone else having this issue? If you don’t have a custom skill, could you try hitting the API and see if you get a 404? The url will be http://YOURHAINSTALLATION/api/alexa

Edit: 2022.2.5 update didn’t fix things.

This should be https://yourdns.com/api/alexa right?

Correct. Fixed my typo in the original post. (I do have it correct in my code on AWS).

Do you get a 404?

nope, it is 405.

405: Method Not Allowed

you should enable this in configuration.yaml, right?


I have the Alexa integration in my config, but not smart_home (had it that way for years). Lemme give that a try.

No luck. Added


and I still get:
404: Not Found

Still broken for me as of 2022.2.6

I tried disabling dialogflow, the Nabu Casa cloud… made sure that intent and intent_script are both in my config yaml.

I’d appreciate anyone that can give me some ideas on where to look for a fix.

Update: When I disable the cloud component, the /api/alexa endpoint works again.

If I have both components enabled, /api/alexa throws a 404 error

Fixed as of 2022.2.8

It was an issue with the setup phase of the cloud component.