Enabling i2c - confused about when to use sda1 vs sbd1 vs mmcblk0p1

Moved my rPi4b to the Argon 40 and am trying to get i2c enabled so as to control the fan and power button. I can access CLI via a keyboard and HDMI to my TV.

I followed the steps below by entering ‘login’ at the ha prompt which gave me a #
I did not see anyway of going into root (typing in ‘root’ at the ha prompt errored and asked if I meant to type ‘host’ for some reason)

Anyway, I input each line as below and after reboot, typed in login to get # and then lsmod | grep i2c which resulted in i2c_dev 20480 0

But I still get errors about i2c not being enabled when trying to start the Argon40 Add on.

Not sure if I should redo the below with sbd1 or mmcblk0p1 as HA instructions are vague only saying " Type the following to enable I2C, you may need to replace sda1 with sdb1 or mmcblk0p1 depending on your platform" - what platform goes with what???

mkdir /tmp/mnt
mount /dev/sda1 /tmp/mnt
mkdir -p /tmp/mnt/CONFIG/modules
echo -ne i2c-dev>/tmp/mnt/CONFIG/modules/rpi-i2c.conf
echo dtparam=i2c_vc=on >> /tmp/mnt/CONFIG/config.txt
echo dtparam=i2c_arm=on >> /tmp/mnt/CONFIG/config.txt
sync
reboot

I just used this:

Which works with this:

And for Argon 40 there is this:

But I think the Argon One version works with the hat.

Thanks

I tried that ‘easy way’ first and it didn’t work which led me to go the official route but that also doesn’t seem to be working - or maybe my result of i2c_dev 20480 0 shows it is and I screwed up the non-configurable plugin?

Figured it out after searching here - looks like the ‘easy way’ has to have protection disabled to work. Did that and now have i2c. Thanks!