Maybe for the start just a way to remove Energy / energy at the end of each item in individual devices?
in yaml maybe create template for each item with custom friendly name?
Maybe for the start just a way to remove Energy / energy at the end of each item in individual devices?
in yaml maybe create template for each item with custom friendly name?
That would be great because right now I have a list of devices in the graph that are all named Energy.
My issue is more because of the friendly_name length:
Energy consumption device name ABC XYZ total
is usually not visible/cut off depending on the screen size (smartphone: not visible at all…).
Being able to rename them just in the energy (configuration) dashboard would really be great.
Agree!
That is a nice feature.
Similar function as we have on the cards, with the “name” option. Then we don’t need to change the friendly name.
I agree editing names would be convenient. Also I would like to group devices like kitchen, garage etc or at least add multiple sensors into one device. For example if I have 3 phase device I would like to group all phases in one to see the total energy it consumes.
I gave up and put this into config.yaml (not all devices, just example)
It is probably possible to do it somehow in gui
template:
- sensor:
- name: "Bojler"
unit_of_measurement: "kWh"
state: "{{states('sensor.bojler_energy')}}"
device_class: energy
state_class: total_increasing
- name: "AC Dílna"
unit_of_measurement: "kWh"
state: "{{states('sensor.ac_dilna_energy')}}"
device_class: energy
state_class: total_increasing
- name: "AC Obývák"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_metter_ac_livingroom_energy')}}"
device_class: energy
state_class: total_increasing
- name: "AC Ložnice"
unit_of_measurement: "kWh"
state: "{{states('sensor.mycka_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Topení koupelna"
unit_of_measurement: "kWh"
state: "{{states('sensor.topeni_koupelna_energy')}}"
device_class: energy
state_class: total_increasing
- name: "TV"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_livingroom_socket_tv_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Xbox"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_livingroom_socket_xbox_energy')}}"
device_class: energy
state_class: total_increasing
- name: "L1"
unit_of_measurement: "kWh"
state: "{{states('sensor.esphome_l1')}}"
device_class: energy
state_class: total_increasing
- name: "L2"
unit_of_measurement: "kWh"
state: "{{states('sensor.esphome_l2')}}"
device_class: energy
state_class: total_increasing
- name: "L3"
unit_of_measurement: "kWh"
state: "{{states('sensor.esphome_l3')}}"
device_class: energy
state_class: total_increasing
- name: "Myčka"
unit_of_measurement: "kWh"
state: "{{states('sensor.ac_loznice_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Pračka"
unit_of_measurement: "kWh"
state: "{{states('sensor.pracka_energy')}}"
device_class: energy
state_class: total_increasing
- name: "PS5"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_livingroom_socket_ps5_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Kávovar"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_kitchen_socket_kavovar_coffee_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Lednice"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_kitchen_socket_lednice_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Osvětlení linky"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_kitchen_socket_lights_linka_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Toustovač"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_kitchen_socket_toustovac_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Varná konvice"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_kitchen_socket_varna_konvice_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Friťák"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_kitchen_socket_xiaomi_fritak_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Nabíječka u gauče"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_livingroom_socket_charger_sofa_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Router"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_livingroom_socket_router_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Trouba + deska"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_metter_trouba_deska_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Asus nabíječka"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_office_socket_asus_charger_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Monitor Lightbar"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_office_socket_lightbar_energy')}}"
device_class: energy
state_class: total_increasing
# - name: "Office"
# unit_of_measurement: "kWh"
# state: "{{states('sensor.zm2_tuya_office_socket_main_energy')}}"
# device_class: energy
# state_class: total_increasing
- name: "Nabíječky nářadí"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_shop_socket_chargers_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Nabíječky na ponku"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_shop_socket_ponk_lampicka_energy')}}"
device_class: energy
state_class: total_increasing
Great idea @evlo, from my Aeotec Switch device I have entities sensor.switch001_electric_consumed_kwh
and sensor.switch001_electric_kwh
: which series the “_energy” entities you were using in your sample does present?
Plus 1 - It look’s somewhat shitty on the web-gui (1) while the windows is large enough.
But on mobile it is worse, due the cutted entity names.
I love the energy dasboard but don’t like that behaviour.
Well, creating redundant sensors with redundant data (basically exact copies) is only a workaround, not a solution.
We still need to template so much stuff because in other sections “features” (like renamig sensors for the energy dashboard…) are missing.
Shadowing data by template sensors is not my personal way to go. Let’s promote this feature request instead, the implementation is probably a XX minutes thing for skilled developers.
yes, it is workaround
but this will add option to feed different real sensor data to the template one, so you can keep history when renaming etc. - obvs, it is, again, workaround for the way the history is kept
from the wth annoyances - my top one is the legend in statistics graph for min/max, then how integration dashboard has so much scrollbars, then energy dashboard names
You can change name of entities:
Note: that do not work for entities that are virtually created with templates. In this case you have to add a friendly_name field in corresponding template.
This is actually the issue. You need to set a global friendly name just for the entities in energy dashboard.
I totally support this feature request so I can set local friendly names for entities in energy dashboard, just as I can do for almost any Lovelace card. I can’t believe this request is over a year old and still not resolved. It can’t be that hard ().
Is there a way of changing the order of the individually monitored devices without deleting and adding them again?
I’d second that.
ALL the entity cards can be customised, so why not the Energy dashboard.
You create meaningful names for the devices at the time they are installed. Changing them after the fact to fit just one particular view is not what HA is about. HA is about taking control, so you shouldn’t HAVE to do something just to make a device work with ONE view. What about the automations that this will mess up.
As has already been said, the mobile browser view has much less space than the desktop browser view, and what about small display screen. Don’t forget the entity names are assigned by each device as its added, so even if you given the device a short name, you’re still left with a big “Energy TOTAL” after the entity name, so every single energy monitoring entity name would have to be renamed.
Also the graphs and views in the energy dashboard really do need some work. They ALWAYS sort in size order, so switching the timeframe changes the order, which is really consusing. Simlarly there’s no way to fix the minimum and maximum on the graphs, they change when the timeframe changes.
I am hunting for where all my electricity goes - I am using a few tools and this is driving me NUTs. PLEASE let us add a friendly name (even just for the dashboard)…
Nopes.
But the order in which they’re added doesn’t matter, as they will be reordered by order of descending energy consumption in the dashboard. So it may change from day to day, depending on how much energy each device has consumed in relation to others.
Thanks. I guess that makes more sense anyways.
The energy dashboard should be just as customizable as a standard card. MY device names are purposefully standardized, as they can change responsibilities if needed by a alias name change.
The inability to do this on the Energy dash reduces its usefulness.
Sorry for the double post, but I just found that if you add them also as individual devices, you can click on them and set a friendly name, which updates the sources as well.
Oh thank you! I never would have guessed that clicking on the bar on the energy dashboard would help with this.
Still should be configurable via the dashboard editor …