It would be great if there was an option to override the default device name for the individual devices on the energy-devices-graph
Does giving them a friendly_name
using customize work?
You can customise the entities you are feeding to the energy dashboard though.
That’s my point - I don’t want to do that - my entities have names like “Plug01-lights daily energy”. I don’t want to change the names of my devices. I would like to be able to change the display name on the graph.
Same.
I have a sensor
sensor.plug_washing_machine_energy
So the friendly name of this sensor should be “Energy”.
But I have to name it “Washing Machine” because the Energy panel would show every single plug named “Energy”.
And friendly naming this sensor “Washing Machine Energy” is also not the good option because when I’m on the device page (the plug, friendly named “Washing Machine Plug”), I know that I am on the Washing Machine plug page !
The best solution would be to be able to override this friendly name in the Energy panel (and only there).
I would like to be able to rename, sort and change the icon for entities I have added to the Individual devices in the Energy section. So the same options entities have within a Lovelace entities card.
Same issue here. Is there no way to edit this in Yaml or something?
Maybe for the start just a way to remove Energy / energy at the end of each item in individual devices?
in yaml maybe create template for each item with custom friendly name?
That would be great because right now I have a list of devices in the graph that are all named Energy.
My issue is more because of the friendly_name length:
Energy consumption device name ABC XYZ total
is usually not visible/cut off depending on the screen size (smartphone: not visible at all…).
Being able to rename them just in the energy (configuration) dashboard would really be great.
Agree!
That is a nice feature.
Similar function as we have on the cards, with the “name” option. Then we don’t need to change the friendly name.
I agree editing names would be convenient. Also I would like to group devices like kitchen, garage etc or at least add multiple sensors into one device. For example if I have 3 phase device I would like to group all phases in one to see the total energy it consumes.
I gave up and put this into config.yaml (not all devices, just example)
It is probably possible to do it somehow in gui
template:
- sensor:
- name: "Bojler"
unit_of_measurement: "kWh"
state: "{{states('sensor.bojler_energy')}}"
device_class: energy
state_class: total_increasing
- name: "AC DĂlna"
unit_of_measurement: "kWh"
state: "{{states('sensor.ac_dilna_energy')}}"
device_class: energy
state_class: total_increasing
- name: "AC Obývák"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_metter_ac_livingroom_energy')}}"
device_class: energy
state_class: total_increasing
- name: "AC LoĹľnice"
unit_of_measurement: "kWh"
state: "{{states('sensor.mycka_energy')}}"
device_class: energy
state_class: total_increasing
- name: "TopenĂ koupelna"
unit_of_measurement: "kWh"
state: "{{states('sensor.topeni_koupelna_energy')}}"
device_class: energy
state_class: total_increasing
- name: "TV"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_livingroom_socket_tv_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Xbox"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_livingroom_socket_xbox_energy')}}"
device_class: energy
state_class: total_increasing
- name: "L1"
unit_of_measurement: "kWh"
state: "{{states('sensor.esphome_l1')}}"
device_class: energy
state_class: total_increasing
- name: "L2"
unit_of_measurement: "kWh"
state: "{{states('sensor.esphome_l2')}}"
device_class: energy
state_class: total_increasing
- name: "L3"
unit_of_measurement: "kWh"
state: "{{states('sensor.esphome_l3')}}"
device_class: energy
state_class: total_increasing
- name: "MyÄŤka"
unit_of_measurement: "kWh"
state: "{{states('sensor.ac_loznice_energy')}}"
device_class: energy
state_class: total_increasing
- name: "PraÄŤka"
unit_of_measurement: "kWh"
state: "{{states('sensor.pracka_energy')}}"
device_class: energy
state_class: total_increasing
- name: "PS5"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_livingroom_socket_ps5_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Kávovar"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_kitchen_socket_kavovar_coffee_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Lednice"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_kitchen_socket_lednice_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Osvětlenà linky"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_kitchen_socket_lights_linka_energy')}}"
device_class: energy
state_class: total_increasing
- name: "ToustovaÄŤ"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_kitchen_socket_toustovac_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Varná konvice"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_kitchen_socket_varna_konvice_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Friťák"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_kitchen_socket_xiaomi_fritak_energy')}}"
device_class: energy
state_class: total_increasing
- name: "NabĂjeÄŤka u gauÄŤe"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_livingroom_socket_charger_sofa_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Router"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_livingroom_socket_router_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Trouba + deska"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_metter_trouba_deska_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Asus nabĂjeÄŤka"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_office_socket_asus_charger_energy')}}"
device_class: energy
state_class: total_increasing
- name: "Monitor Lightbar"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_office_socket_lightbar_energy')}}"
device_class: energy
state_class: total_increasing
# - name: "Office"
# unit_of_measurement: "kWh"
# state: "{{states('sensor.zm2_tuya_office_socket_main_energy')}}"
# device_class: energy
# state_class: total_increasing
- name: "NabĂjeÄŤky nářadĂ"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_shop_socket_chargers_energy')}}"
device_class: energy
state_class: total_increasing
- name: "NabĂjeÄŤky na ponku"
unit_of_measurement: "kWh"
state: "{{states('sensor.zm2_tuya_shop_socket_ponk_lampicka_energy')}}"
device_class: energy
state_class: total_increasing
Great idea @evlo, from my Aeotec Switch device I have entities sensor.switch001_electric_consumed_kwh
and sensor.switch001_electric_kwh
: which series the “_energy” entities you were using in your sample does present?
Plus 1 - It look’s somewhat shitty on the web-gui (1) while the windows is large enough.
But on mobile it is worse, due the cutted entity names.
I love the energy dasboard but don’t like that behaviour.
Well, creating redundant sensors with redundant data (basically exact copies) is only a workaround, not a solution.
We still need to template so much stuff because in other sections “features” (like renamig sensors for the energy dashboard…) are missing.
Shadowing data by template sensors is not my personal way to go. Let’s promote this feature request instead, the implementation is probably a XX minutes thing for skilled developers.
yes, it is workaround
but this will add option to feed different real sensor data to the template one, so you can keep history when renaming etc. - obvs, it is, again, workaround for the way the history is kept
from the wth annoyances - my top one is the legend in statistics graph for min/max, then how integration dashboard has so much scrollbars, then energy dashboard names
You can change name of entities:
- Go to dev tools
- Ctrl-F to open browser search box
- type entity name to look for
- click on more-info icon (i in circle)
- select settings tab
- choose or edit name
Note: that do not work for entities that are virtually created with templates. In this case you have to add a friendly_name field in corresponding template.
This is actually the issue. You need to set a global friendly name just for the entities in energy dashboard.
I totally support this feature request so I can set local friendly names for entities in energy dashboard, just as I can do for almost any Lovelace card. I can’t believe this request is over a year old and still not resolved. It can’t be that hard ().