Energy Dashboard: Adding Energy and Water consumption

Hi Home assistant community,

I am pretty new to the topic and want to add my current energy consumption and also water consumption to the energy dashboard.

First problem is now the energy.
I have an infrared reader with ESP that currently reads my total consumption value and transmits it over MQTT to the Tasmota integration. So far so good, I can see the value in Home assistant:


The problem now is that I cannot select that sensor in the energy dashboard. It is just not shown up in the drop down. Any idea what I am missing here?

The same problem I have for the water consumtion. Here I have the reading also over AI-on-the-edge and ESP camera. The value is correctly shown in Home Assistant.

But also on the energy dashboard this sensor is not shown in the drop down.

Is there anything else I need to configure in order to use them in the dashboard?

Any help would be appreciated. Thank you!

The energy sensor must have all of these attributes:

A state_class of total or total_increasing
A device_class of energy
A unit_of_measurement of Wh or kWh (I can see you have that one).

Similarly the water sensor must have the attributes:

A state_class of total or total_increasing
A device_class of water
A unit_of_measurement of L, gal, m³, ft³, or CCF

Check in Developer Tools → States. Look in the right hand column for your sensors.

Thanks for the reply. I checked the sensors there. I also tried to customize them in the config.yaml by setting those attributes.
I can see that those attributes are set:

However, the energy dashboard still says “No matching statistics found”

Wait a bit for statistics to be generated.

Well at least for the water consumption this is running for days now

Check in Developer Tools → Statistics. Are there any FIX ISSUE buttons you can press?

Indeed there was a fix me button for some sensor and it solve the issue for the current power consumption, thanks.

However, the water consumption is still an issue. There in the options I only get this:

The sensor is not showing up there. However for current “gas” consumption I could select the water sensor. Also when I try to create a normal statistics diagram I get only “statistics are being loaded” forever for the water sensor. Sometimes some values are showing up but then switch back to “loading”.