Energy Dashboard can't (re)select entities. Did I miss a breaking change?

After a while I had a look at my energy dashboard and it is suddenly empty…

Did I miss a breaking change? I tried to re-add my gas usage (m with small 3 m3) but it won’t use it anymore…

What am I missing?

maybe the sensor.gas_con_ … should be

I do not get what you mean

device_class energy

Im not familiar with you “energy” API, and not GAS_Consumption / GAS_Calculation either

It worked wel with these DSMR sensors since the beginning of the energy panel up untill I noticed today.

The energy sensors are the default/standard DSMR sensors. And the gas one it also a standard entity from it…

if they are sensor.power… they should be…
DSMR sensors, i know nothing of

as you see, i know nothing about gas :slight_smile:

thou a resent similar issue is here
EDIT: …sorry

other-vice is seems more like requests for various gas-meters etc lately … been hanging here for month, building up my HA :laughing:

Have you seen my 1st screenshot? That’s correct isnt it?

seems so
regarding all the “missing” entities (not_defined / not_tracked) can’t tell from a dashboard_view

Please read again. The entities are ot missing.

How Does it look like if/when you read direct from the sensor ? (pic2) does it count up properly, or just shows “current_consumption”

yes i saw not_defined/not_tracked … as i dont see annything else, in my eyes “missing” :slight_smile:

btw have you tried unit_messurement “m3” small 3 as is ? : " "

Don’t expect i can make any “sense” by seeing a screen_shot( in regards to the “entities not_defined/not_tracked”) your configuration-files and log-file is your best shot here

EDIT: In regards to the Grid_consumed/grid_return (with 2 tarifs), also there your config_files, and logs are relevant, and the documentation, regarding 2 tarifs(if it comes from 1 sensor, or ?)

All my sensors report fine. Always did. And it always worked until recently. Only thing I did was exclude “them” from recorder because I have all historical data via influxdb. Might be that the energy tab is relying on “recorder”… but that would also not make sense since I had a cap on recorder for 2 days and I could see weeks/months of historical energy tab data.

Anyone else able to jump in and en-light?

EDIT: enabled recorder again… and I can select the entities again in energy dashboard.

My main question now is:
How can I excluded them from recorder but use them in energy dashboard?

I will open a new topic.

yes, energy uses “recorder”, so i wouldn’t exclude this … and influx uses the homeassistant_db as well, if you haven’t some “other” solution from default
edit: i assume you know “recorder” is as it says “Record-er” not a database
edit2: record=make a record. Store: store record in db (or ram, gone when reboot). … Make a record>use elsewhere = present time( equal to real-time sensor)