Energy dashboard no data to show

Hi all,

I tried setting up the energy dashboard yesterday. After a full day there is still no data to show.

I’m using a Shelly EM module with a CT clamp on the grid cable and a CT clamp on the solar circuit cable. HASS is receiving valid data from the sensors.
Channel 0 is the grid clamp.
Channel 1 is the solar clamp.

I’ve configured the dashboard to use these entities:

Grid consumption: sensor.shelly_em_e5_meter_energy_0
Return to grid: sensor.shelly_em_e5_meter_returned_energy_0
Solar Panels: sensor.shelly_em_e5_meter_energy_1

These are the attributes of each sensor:

state_class: measurement
unit_of_measurement: Wh
device_class: energy
friendly_name: <sensor name>
last_reset: 1970-01-01T00:00:00+00:00

The last reset data was added with this customize setting:

      last_reset: "1970-01-01T00:00:00+00:00"

The data does record fine, I can show graphs with the statistics-graph card.
Schermafbeelding 2022-06-15 110808

How can I fix the energy dashboard so it starts displaying data?
Did I use the right entities for the energy? Or should I use the total energy entities?

Kind regards,

You need to use the totals.

1 Like

Thanks, it is working now. :grinning:


I’ve bought a Shelly 3EM, but am unable to select the total entity’s. I’m only seeing the energy entities. This is on HASS 2022.8.7.

Strange because it has the same attributes as my Shelly EM on my home HASS installation (2022.6.7):

Any ideas?

PEBCAK… :see_no_evil:

I was not recording the total values :unamused:

1 Like