Energy meter Orno51x and modbus

Hi,
I change platform from Openhab to Home Assistant, but my problem is to set energy meter orno 51x via modbus in HA,

In OH2 my cfg see like that

serial.home_freq.connection=/dev/ttyUSB0:9600:8:even:1:rtu:150:1000:none:none
serial.home_volt.connection=/dev/ttyUSB0:9600:8:even:1:rtu:150:1000:none:none

poll=5000
serial.home_freq.type=holding
serial.home_freq.id=1
serial.home_freq.start=20
serial.home_freq.length=2
serial.home_freq.valuetype=float32

serial.home_volt.type=holding
serial.home_volt.id=1
serial.home_volt.start=14
serial.home_volt.length=6
serial.home_volt.valuetype=float32

In HA i have only this

modbus:
  type: serial
  name: hub
  methos: rtu
  port: /dev/ttyUSB0
  baudrate: 9600
  stopbits: 1
  bytesize: 8
  parity: N

And error

Invalid config for [modbus]: [methos] is an invalid option for [modbus]. Check: modbus->modbus->0->methos. (See /config/configuration.yaml, line 261).

someone can help me finish the configuration so that I can get the data from the energymeter?

my yaml

modbus:
  type: serial
  name: orno51
  method: rtu
  port: /dev/ttyUSB0
  baudrate: 9600
  stopbits: 1
  bytesize: 8
  parity: N
  timeout: 2
  
sensor:
 - platform: modbus
   scan_interval : 5
   registers:
     - name: home_volt
       hub: orno51
       slave: 1
       register: 14
       count: 6
       data_type: float

     - name: home_freq
       hub: orno51
       slave: 1
       register: 20
       count: 2
       data_type: float

     - name: home_curr
       hub: orno51
       slave: 1
       register: 22
       count: 6
       data_type: float

     - name: home_power
       hub: orno51
       slave: 1
       register: 28
       count: 8
       data_type: float

     - name: home_energy
       hub: orno51
       slave: 1
       register: 256
       count: 8
       data_type: float  

error

2020-02-27 19:41:26 WARNING (SyncWorker_15) [pymodbus.client.sync] Cleanup recv buffer before send: 0xfc
2020-02-27 19:41:26 ERROR (SyncWorker_15) [homeassistant.components.modbus.sensor] No response from hub orno51, slave 1, register 20
2020-02-27 19:41:32 WARNING (SyncWorker_2) [pymodbus.client.sync] Cleanup recv buffer before send: 0x3e
2020-02-27 19:41:32 ERROR (SyncWorker_2) [homeassistant.components.modbus.sensor] No response from hub orno51, slave 1, register 20
2020-02-27 19:41:38 WARNING (SyncWorker_4) [pymodbus.client.sync] Cleanup recv buffer before send: 0x5d
2020-02-27 19:41:38 ERROR (SyncWorker_4) [homeassistant.components.modbus.sensor] No response from hub orno51, slave 1, register 20
2020-02-27 19:41:44 WARNING (SyncWorker_14) [pymodbus.client.sync] Cleanup recv buffer before send: 0x5f
2020-02-27 19:41:44 ERROR (SyncWorker_14) [homeassistant.components.modbus.sensor] No response from hub orno51, slave 1, register 20

It should be method, not methos, as reported here: https://www.home-assistant.io/integrations/modbus/

Ok i change and now

error
Unable to detect data type for home_energy sensor, try a custom type

modbus:
  type: serial
  name: orno51
  method: rtu
  port: /dev/ttyUSB0
  baudrate: 9600
  stopbits: 1
  bytesize: 8
  parity: N
  timeout: 2
  
sensor:
 - platform: modbus
   scan_interval : 5
   registers:
     - name: home_volt
       hub: orno51
       slave: 1
       register: 14
       count: 6
       data_type: float
     - name: home_curr
       hub: orno51
       slave: 1
       register: 22
       count: 6
       data_type: float
     - name: home_power
       hub: orno51
       slave: 1
       register: 28
       count: 8
       data_type: float
     - name: home_energy
       hub: orno51
       slave: 1
       register: 256
       count: 8
       data_type: float

I suggest you to test one data at a time.
Then, the example in modbus page does not leave blank lines.

Hello Bartosz

Did you fixed your problem?
I have similar meter and similar problems :wink:
But at first you had the wrong parameter:
parity: N
It should be:
parity: E
“Even” just like you had in OH2 config.
But even after this setting, I still have a problem with reading the registers

regards

has anyone been able to read the data from a three-phase orno?