Energy usage not working anymore (I think after latest update)

I’ve been running import and export grid sensors for a while now and worked without any issues till yesterday…

I think the update is messing up how the values show on the dashboard. This is the day after the update (the 15th):

I’ve definitely not consumed the same amount as my solar produced.

Anyone else running into this?

This is my actual production and consumption from that same day.

and for today the 16th it looks like the dashboard is skewed as well. Its only 08AM here and in the middle of the night I have exported 64.2kw to the grid but only generated 3.2kw…

What version of HA? “latest update” isn’t specific.

Just looking at it I would say whatever data feed you use for your consumption figures failed about 9:00am. Have you looked at the entities in Developer Tools? What does that show?

And it looks like whatever failed yesterday started working again overnight and fed you all the missing data in one bunch.

Wait for the next update and see what it looks like.

Thanks for taking the time. It started when I installed this update yesterday (the 15th) Release 2022.12.6 · home-assistant/core · GitHub

The entitities look fine

I have a very similar problem. My energy tab looks like this after update

Please help
Mr Anders


WOW! You fixed it.

Big, big thanks

Mr Anders

@AnWi I have the exact same issue, what fixed it if you don’t mind sharing.

@AnWi @smuggaz please let me know if and how you fixed it. Same issue here! (running 2023.2b7)

Home Assistant 2023.2.0b1
Supervisor 2023.01.1
Operating System 9.5
Frontend 20230125.0 - latest

fyi after clearing the cookies and sitedata in Edge for the HA site I have my graphs back.

@hapklaar glad that worked for you, I tried an incognito browser and new installation of firefox and its the same on all three for me.

Latest Update - Fixed the problem

Home Assistant 2023.2.0
Supervisor 2023.01.1
Operating System 9.5
Frontend 20230201.0 - latest