Enitity / expose TS0601 thermostat radiator valve missing

I’ve a TS0601 thermostat radiator valve (_TZE200_hue3yfsn) that’s missing the entity/expose “current_heating_setpoint”. So I’m unable to configure the current heating setpoint from HA.
From zigbee2mqqt I see this specific expose and I can configure it without any problems.
I already tried to remove and re-pair this device, but that doesn’t solve the issue.

I’m using HA 2022.9.7 and Zigbee2mqqt 1.28.0 commit: 03ba647. The upgrade to HA 2022.10 makes no difference.

Below a picture from z2m & HA:

I fitted the same TRV this week, you can see in Z2M its currently set to 20c :

In developer tools, I can see the temperature and current heating setpoint, set to the same.

I don’t recognise where your screenshot with the green border is from, let me know and I will check there too.

From the dashboard I click on the three points and then I select the most right tab ‘Related’.
From the developer tools I also see the current _heating_setpoint, but it’s unavailable when creating an automation.
From Z2M I can also change the current heating setpoint.
Are you able to set the current heating setpoint from an automation?

This worked

service: climate.set_temperature
  temperature: 17
  entity_id: climate.kitchen_radiator
1 Like

Many thanks Tim! It works for me too.
I’m just new to HA, so it wasn’t clear for me it’s working in this way.

You made my day: I’m more HA experienced on the end of this day than at the start of it. Thx! :smile:

1 Like