Enmax Energy integration fails

I just saw the release notes and added the new Enmax Power integration. It’s failing with the following error:

> Logger: homeassistant.config_entries
> Source: config_entries.py:441
> First occurred: 3:32:24 PM (3 occurrences)
> Last logged: 3:59:07 PM
> Config entry 'Enmax Energy ([email protected])' for opower integration not ready yet: 403, message='Forbidden', url=URL('https://enmx.opower.com/ei/edge/apis/multi-account-v1/cws/enmx/customers?offset=0&batchSize=100&addressFilter='); Retrying in background

I copied that url into a browser, and see this:

    "httpStatus": 401,
    "serviceErrorCode": "Unauthorized",
    "details": "Claims could not be validated: Not logged in web user."

Obviously looks like an authentication issue, but I have triple checked my credentials and they are correct. Thanks for any help.

Tried a reboot and now getting this error:

Logger: homeassistant.config_entries
Source: config_entries.py:423
First occurred: 4:30:48 PM (1 occurrences)
Last logged: 4:30:48 PM

Config entry 'Enmax Energy ([email protected])' for opower integration could not authenticate: Sorry, an error occurred retrieving or updating data. Please try again later, or call our Customer Care centre at 310-2010 for assistance.

Maybe an issue on their end?

Are you seeing any data now? I see monthly usage going back about 4 months

No, still not working for me. Do you use EasyMax, by chance? I don’t and just noticed that I can’t even access any energy data on the Enmax website.

I set mine up and it’s not working either. Mine appears to have logged in but there’s no data in my stats.

Where do you access it on the website? I can’t even find that to be honest.

I see the information in the Home Assistant Energy dashboard. August is the most recent for some reason.

I have EasyMax. Do you get the ‘My EnergyIQ’ tab on the left side on the Enmax site?

I think that’s the problem. I’m not on EasyMax and don’t see that tab nor any detailed energy use information.