Entities unavalible - MQTT Connection


I have just updatet to a new HASSIO version. But now I have to problem that all my MQTT Devices are not longer working. Here some details:

After the update I noticed that all my devices are showing a status of unavailable:

After some digging, I found out that I needed to implement unique IDs. So I did that in the configuration. But I still hat the “unavailable” Problem. Then I found out the the MQTT is not working. And now I am trying to fix it.

I have to following errors:

My Broker is configured as following:


When I try to connect to in manually I get the following error:

I think that there is some error with the login, but I can not figure it out. I hope someone has an idea.


A update:
I potentially found part of the problem. I have now the right login data so I can connect. But it is still not working. Not even on the same device.
I have followed Home Assistant MQTT Install and Setup - A Beginner's Guide - YouTube. At the 7:25+ he is trying the configuration. And this is exactly what does not work. I can publish what I want it does not show up.


under Listen to a topic, the pupliched payload schould appear.

First entry.

Thanks for the answer!
Yes I have changed this. The Problem lies in the MQTT Login. In the meantime I have tried some thinks. I have managed to connect to MQTT. I have reinstalled MQTT and adjust the login user. The Problem was that I was using a MQTT login without password or username. It seems that is no longer possible with the standard configuration. Now I am trying to implement anonymous login. (see: c# - Unable to anonymously connect to Mosquitto 2.0.5 on Ubuntu - Stack Overflow). But I have not managed to get it to work. If I am not able, I have to get and update al the firmware on all devices. I have tried to set up a musquitto.conf:

Hassio is loading bit if it seams to have no effect. If I ad “listener 1883” than I cant connect at all.