Entity id of Xiaomi roborock (rockrobo?) vacuum

Tags: #<Tag:0x00007f739b9f4c08> #<Tag:0x00007f739b9f4a78>

I cannot change settings of the vacuum from the UI:
“This entity does not have a unique ID, therefore its settings cannot be managed from the UI.”

This is its state:

fan_speed_list:
  - Silent
  - Standard
  - Medium
  - Turbo
  - Gentle
battery_level: 88
battery_icon: 'mdi:battery-90'
fan_speed: Standard
do_not_disturb: 'on'
do_not_disturb_start: '22:00:00'
do_not_disturb_end: '08:00:00'
cleaning_time: 23
cleaned_area: 22
cleaning_count: 134
total_cleaned_area: 9340
total_cleaning_time: 11959
main_brush_left: 100
side_brush_left: 175
filter_left: 125
sensor_dirty_left: 5
status: Cleaning
clean_start: '2020-03-30T12:07:28'
clean_stop: '2020-03-30T12:16:28'
friendly_name: Xiaomi Vacuum cleaner
supported_features: 14204
entity_id: rockrobo-105

This is the config:

xiaomi_aqara:
  discovery_retry: 20
  gateways:
    - mac: 7811dcb78c58
      host: 192.168.10.100
      key: up99XXXXXXy98

vacuum:
  - platform: xiaomi_miio
    host: 192.168.10.105
    token: 5352XXXXXXX744f

Setting entity_id in either file config or web UI does not have an effect, I can only change the friendly name this way. One of the answers I found that I cannot set it as it is set by the integration (which is what, my Xiaomi Control Hub?), however the vaccum itself goes to the internet via wifi and at least in theory does not need a hub, or did Xiaomi screw this part too?

Is there a way to enable the vacuum settings from the UI? Thanks,

1 Like

I have the same issue and I have not found a solution for this yet.

one of these weirdly hacked old xiaomi apps helped but I cannot recall details and after all the whole integration is quite useless as I run the vacuum manually anyway (homeoffice because of covid)