Entity not found - local tuya

I am a newbie but hoping someone can help. I have been using a thermostat through local tuya integration. It all worked fine but suddenly HA says ’ Entity not available’. I tried to remove the integration and add again, but now I get this error. Anyone else had similar issue?


Logger: custom_components.localtuya.config_flow
Source: custom_components/localtuya/pytuya/init.py:637
Integration: LocalTuya integration (documentation, issues)
First occurred: 7:42:49 (1 occurrences)
Last logged: 7:42:49

Unexpected exception

Traceback (most recent call last): File “/config/custom_components/localtuya/config_flow.py”, line 279, in async_step_basic_info self.dps_strings = await validate_input(self.hass, user_input) File “/config/custom_components/localtuya/config_flow.py”, line 185, in validate_input interface = await pytuya.connect( File “/config/custom_components/localtuya/pytuya/init.py”, line 637, in connect _, protocol = await loop.create_connection( File “/usr/local/lib/python3.8/asyncio/base_events.py”, line 1025, in create_connection raise exceptions[0] File “/usr/local/lib/python3.8/asyncio/base_events.py”, line 1010, in create_connection sock = await self._connect_sock( File “/usr/local/lib/python3.8/asyncio/base_events.py”, line 924, in _connect_sock await self.sock_connect(sock, address) File “/usr/local/lib/python3.8/asyncio/selector_events.py”, line 496, in sock_connect return await fut File “/usr/local/lib/python3.8/asyncio/selector_events.py”, line 528, in _sock_connect_cb raise OSError(err, f’Connect call failed {address}’) OSError: [Errno 113] Connect call failed