Environment, Canada

I noticed in the last day or two that the add-on stop working. I’ve tried to reinstall with no luck.

Is anyone else having problems?

Mine is working, but I do see some error in the logs, what kind of problem do you have?

2023-08-25 11:36:26.240 ERROR (MainThread) [homeassistant.components.environment_canada] Unexpected error fetching environment_canada radar data: cannot identify image file <_io.BytesIO object at 0x7f2d878249f0>
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/update_coordinator.py", line 283, in _async_refresh
    self.data = await self._async_update_data()
  File "/usr/src/homeassistant/homeassistant/components/environment_canada/__init__.py", line 117, in _async_update_data
    await self.ec_data.update()
  File "/usr/local/lib/python3.11/site-packages/env_canada/ec_radar.py", line 329, in update
    self.image = await self.get_loop()
  File "/usr/local/lib/python3.11/site-packages/env_canada/ec_radar.py", line 356, in get_loop
    frames.append(await self._combine_layers(f, frame_times[i]))
  File "/usr/local/lib/python3.11/site-packages/env_canada/ec_radar.py", line 258, in _combine_layers
    radar = Image.open(BytesIO(radar_bytes)).convert("RGBA")

Won’t even connect anymore. Woke up the next day, and can’t get it to connect.



The error look like it lost the station IDs setting, did you try to remove it and reinstall?

Yes, that’s what I’m doing now. I removed it, and trying to install again.

I think you’re right about this. I just specified another location and it worked.

Is there anywhere I can check what the latest weather ID is, and just punch it in?

I think the app get the weather ID from the csv list Environment Canada - Home Assistant , if the ID has changed, you probably need to report an issue.
You can also follow this link How to Get Environment Canada Climate Station ID From Name | Michael Yu , the site has change, so you need to click around, I was able to find the station ID.