Envisalink rejecting my credentials - help?

Brand new user, so very inexperienced…

I keep getting a message in my log stating:

16-09-05 04:26:13 pyenvisalink.envisalink_base_client: Password is incorrect. Server is closing socket connection.
16-09-05 04:26:13 homeassistant.components.envisalink: The envisalink rejected your credentials.
16-09-05 04:26:14 homeassistant.bootstrap: component envisalink failed to initialize

The password in the configuration.yaml file is exactly the same as the one I am able to use to log into the envisalink device directly.

What am I doing wrong here?

Replying to my own post, in case anyone else encounters this problem in the future.

It turns out that no matter how many characters you use in the password, the EVL3 only looks at 6 characters. On the web interface, if you enter more than 6 characters, it appears to (silently) truncate the password to the first 6 characters automatically. However, when accessing the device from the API that Home Assistant uses, it seems that it will ONLY accept 6 characters - attempting to use the 7th (or more) character in the configuration.yaml file will throw the error I detailed in my prior post.

Hope this helps someone else!

1 Like

I’m running into the same problem. I changed my password to contain only 6 characters, but it’s still being rejected. Is there something else I’m missing?

I use a EV3 with a 4 character password which work on the website and with HA. It might be worth a try.

I changed it to 4 character and that seemed to work. Thanks!

FYI with envisalink 4 it works with 6 characters. With 10 char password I got: [pyenvisalink.envisalink_base_client] Password is incorrect. Server is closing socket connection.

Seems like my envisalink is not even working with 4 characters.
Also I am confused by the instructions for honeywell it says use the same username password for honey well.
For example my user name is [email protected] and password is 9999

I have tried and tested with both

  user_name: [email protected]
      password: [email protected]

as well as

user_name: [email protected]
password: 9999

But keep on running into the same issue where it says Envisalink rejected your credentials

@ahaneo, I am also having the same problem as you with EV4. Were you able to resolve your? If so how?

Hi - also wondering if anyone solved this.

I have evl3 with dsc.

set up as per instructions - using direct login details (which work on my browser)

had 5 digit password - changed to 4 digit but still getting same error.

any help really appreciated (newbie)

Solved----
I was using 4 digits - changed to 4 lower-case letters and now working on restart.

still having this “incorrect password” issue with EVL4 and even 4 characters

Hi everyone,

I am also running into this same issue. Just installed evl4 with no issues, and can log into the web interface np.

I tried the various password lengths, characters vs number, and 4 vs 6 character lengths, but still having the same error messages:

//
Setup failed for envisalink: Integration failed to initialize.
10:34:08 PM – (ERROR) setup.py

The Envisalink rejected your credentials
10:34:08 PM – (ERROR) envisalink

Password is incorrect. Server is closing socket connection.
10:34:08 PM – (ERROR) /usr/local/lib/python3.9/site-packages/pyenvisalink/envisalink_base_client.py
//

Can anyone help???

Thank you!
-M

Ok, figured it out, based on some other forum posts from other smarter folks.

There are two Envisalink accounts.
1 - The account that you use on the website
2 - The account that’s set up on the device itself, for use with local API calls.

The envisalink integration in home assistant actually cares about the second.

That credential defaults to u:user pwd:user. (Yes, really. But by default, it only allows access with that credential from the local subnet. That sounds like security, but isn’t, in this world of compromised IoT devices… but I digress).

So - you can use that set of credentials in the envisalink configuration.

But I’d recommend that you change it first. How?

  1. Browse on your home network to http://ip-of-envisalink-on-your-lan.
  2. When prompted, enter the default user/user.
  3. Click on Network in the upper right.
  4. Change the password.
  5. Winning!

Then, you can use this credential with home assistant - and smile!

1 Like

Waw man this was a lifesaver. I have spend hours trying everything without any success. I didn’t even know that Envisalink had this internal account. Many many many thanks. thumbs UP!!!

Thanks for this, I had updated the password on my Envisalink and it started failing. I wouldn’t have started my troubleshooting by assuming the password was being truncated.