EQ3 Bluetooth Fix for Broken firmware

Got a new EQ3 could see it with Bluetoothctl scan on in ssh. Took note of the mac and added it to HA under climate but it remained unavailable.
Tried to connect by Calor BT app on my phone but when went into pairing it gave pin 000-255. App would accept it. Apparently earlier in year an update broke the device.
Bought the eq3 from ebay. Previous owner obviously couldn’t connect by bluetooth. Bit sneaky they didn’t mention that.
Found a site: Recover EQ3 firmware
Big thanks to Sven Eckelmann.
On that site I entered my serial code from the battery compartment and it gave me the 4 digit code I had been expecting.
Now I paired the Calor Bt app and it accepted the generated 4 digit code. Added the device and updated the software.
Deleted the old device on the Calor Bt app and added the device again via Teach-in device, press the wheel on the eq3 and new 6 digit code showed up
and a different pop-up appeared into which the 6 digit code worked.

So went back to ssh on HA and typed:
~ bluetoothctl #and then
~ scan on #Saw the eq3 mac was there
~ scan off
~ agent on # Don’t know if this was necessary
~ pair 00:1A:22:12:xx:xx #(my eq mac)
#It asked for passkey so typed in 6 digit code with no spaces.
#It paired.
~ trust 00:1A:22:12:xx:xx
~ disconnect 00:1A:22:12:xx:xx
~ quit

Left ssh and added new climate card for device and it worked. :grin: :nerd_face:

1 Like