[Errno 2] No such file or directory

Hi,

it happened out of nowhere. I can’t even recall if there was any restart of HA - but I assume this must have triggered it.

I am using command line to control Onkyo receiver. Until recently I run a script which would turn on the receiver and dial radio station from TuneIn.

It stopper working. I get error:

[Errno 2] No such file or directory: onkyo

In logs I can see:

File "/usr/local/lib/python3.12/subprocess.py", line 1955, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: 'onkyo'

My command line is defined in configuration.yaml:

shell_command:
  onkyo_command: onkyo --host {{ ip }} {{ cmd }}

when I check for onkyo via terminal I can see:

~ ls -l /usr/bin/on*  
-rwxr-xr-x    1 root     root           209 Jul  6 17:01 /usr/bin/onkyo

Would you have any idea how do I resolve this?

Regards,

Maciek

Hi there

I’m facing exactly the same issue. It worked for many years and suddenly stopped working since a few a days.

Errno 2] No such file or directory: ‘onkyo’

I guess this is due to that change:

A side-effect is likely that you lost the onkyo command inside HA.
I guess it wasn’t documented as a breaking change because one wasn’t supposed to use that command in the first place

Thanks. How do I utilize this now for managing my Onkyo?

My guess is that you can’t beyond what is documented.

If you are desperate, you can create a custom component from an earlier version of the integration

Thank you, it worked.

Regards,

Maciek

Any reason you’re not simply using the built-in integration?

Yes. I was never able to run a station on TuneIn.

As far as I could see in Integration description NET radio is not supported for play_media function.

Unless there is a way I do not know?

Yeah, play_media can currently only be used for normal radio, not NET radio. But if it is possible to send the proper codes manually, then it should also be in principle possible to support it in the integration.

Would you have an example of how to send follwing sequence of codes using the standard integration:

ZPW01
ZLKV15
SLZ2B
NSV0E0
NLSI00001
NLSI00008

with some delay between them?

Regards,

Maciek

1 Like

Just want to share an alternative method to bring back the now missing onkyo dependency.

By following this advice I was able to re-install the required onkyo-eiscp dependency without the need to create a custom component.

Fingers crossed the solution will stand the test of time :slight_smile:

1 Like

Can you list the steps you took to correct? Which files did you pull? I am having the exact same issue.