Error 400 updating location, battery level works, other devices work fine

I recently migrated to (great stuff) from python virtual.
Before I had my phone and my wife’s phone updating location as it should.

After installing my phone and ipad work like a charm. My wife’s phone however keeps generating a 400 error in the app instead of replying the one shit location uodate succeeded.
Tried uninstalling, older versions. All the same, also changed the devicename, no solution.
As it does update the battery-level it does seem to connect somehow, but not for location.

Connecting it back to my old ha instance I get the same error where it worked before. So my guess is somehow the app got screwed up.

Any tips?

I renamed the device_id to 123, worked, renamed to jessica_iphone it’s broken, renamed to jessica__iphone, also broken… renamed to jessica, it works.
my device-id also has an _ in it, so that shouldn’t be the issue…

No clue, just happy it works now :slight_smile:

Where did you rename the device id? I’m having similar problems where the iPhone can’t even finish the setup.