Error 404 When Setting up iOS app with Nabu Casa

Hello. I started my 1 month Nabu Casa trial. After a couple of minutes, I was given a url to use. I tried to use this URL on my Windows 20 laptop and it worked as expected. I opened the URL in my Safari browser in my iPhone and it also worked. However, when I used the URL to setup my Home Assistant app on my I phone, after placing my login and password, I’m given the following error: “Error. Response status code was unacceptable: 404.”

I am getting this error whether I do this in my home network or using my 4G LTE connection.

Had this same issue, you have to use your local IP to set up The Home Assistant iOS app. Then it figures out that you have Nabu Casa and it will set it up for you.

Please make sure you check “Connect via Cloud” in connection settings.

I also had to disable LetsEncrypt and remove certificate information from configuration.yaml, because the app denies a invalid local https connection. Nabu Casa will create the secure connection for you for remote access. (Remember to remove any port forwarding settings)

Thanks you so much for this information!

Just for future reference for people who find this. Make sure when entering the URL you don’t include a / at the end.

Some notes on setup with Nabu Casa are here