Error Adding integration


I installed Home-Assistant stable with docker-compose.
After onboarding I want to add the integration “Homematic”.
But it stops with the Error:
Config flow could not be loaded: {“message”:“Invalid handler specified”}

What am I doing wrong?

Any hint is welcome.

1 Like

Same to me. Also tried this yesterday.
Maybe there was a change during the last days?

I downgrade from latest (amd64 9ed649f5b10f) to 2022.10.5. Now a another screen is shown.

Where should I raise the issue?

Same, just tried to add “Microsoft Speech to Text”.

Hi Schlusi, same thing happened here.
First installation ever on a raspberry pi 4, no problems with different devices from other manufacturers, several entities of Homematic available after configuration of the configuration.yaml, but none of them shown as a device.
When I try to install the Homematic integration there comes the same error message.
A bit frustrating when you’ve installed Homematic IP Wired in your house. It’s the only reason why I’ll stay at ioBroker as my core system for the moment. But only until I figured out the problem with Homematic. :wink:

having the same issue when installing the “Honeywell Total Connect Comfort (Europe)” integration…

Having the same issue with MQTT Room Presence and I don’t know how to proceed (I’m a newbe). Regards

I have the same thing happening for the EQ3 integration.

1 Like

I’ve checked some of the mentioned integrations. My conclusion is that they all should be manually configured, using the yaml configuration. There isn’t a UI configuration flow available yet, for these specific integrations.

There is already a bug report filed, to prevent the error for these integrations in the UI: Yaml only integrations in submenus error with Config flow could not be loaded: {"message":"Invalid handler specified"} · Issue #14376 · home-assistant/frontend · GitHub

Of course, the integrations can be used, but to do so you need to use the yaml configuration. The correct way to do this varies per integration and can be found here: Integrations - Home Assistant

Update: Fixed in “Release 2022.11.3 - November 16”

In my case that is not the behaviour, and I’m refering to the #ONVIF integration that has UI support.
Refer to:

I get this trying to add the integration from the UI:

And even if I try by .yaml I get validation error, when I know the code is right:

  - platform: onvif
    name: CamaraCave
    username: username
    password: password
    port: 5000

On validation .yaml:
I get this:

This is an official integration, so for me is not “Fixed”.
Thanks in advance.

It seems that you have you have a custom integration downloaded (probably in the custom_components folder or by something like HACS) for this package (the box icon).

1 Like

Really??? Well, in my list of HACSintegrations I don’t have nothing named ONVIF, but I will check my custom_components folder as soon as I get home. You might be right, and if that is the case, I’m very thankfull to you! :slight_smile:

Same problem with Dyson integration :frowning:

1 Like

Solved ALONE. Config flow could not be loaded: {“message”:“Invalid handler specified”}

  • Deleted integrations in hack.
  • Deleted directories in custom component (with terminal).
  • Restart Home Assistant.
  • Used terminal (python3 to discover serial credential etc…
    initially it didn’t work because I had disconnected the account from the mobile phone.
  • I logged in with my phone, ran python3 again and it worked.
  • In home assistant I only installed the hacs dyson local component.
  • Restarted home assistant
  • Launch dyson local and it worked choosing dyson hot+cool (i have hp06)


1 Like

Also getting this error on Dyson cloud


in my experience, invalid handler happens when the folder name does not match the DOMAIN name.
Maybe some refactor has caused this discrepency? obscure error indeed, but this is one thing worth checking.

1 Like

It was this.