Error after updating Zigbee2mqtt - Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)

Ive been a bit slack with updating HA lately (last update was couple/few months ago). But when i tried updating recently, my zigbee2mqtt has been failing to start. I can run it just fine with the older version (im running on a VM through proxmox, so i can easily just roll back which i have done - rolled back to old version yet again while i hear some suggestions).

For context im a bit noob at this, so bare with me. i use a athom ethernet zigbee adaptor/coordinator (the cordinator is a standalone device thats connected to my local network via ethernet, and zigbee2mqtt connects to it via ip/port). The adaptor/coordinator is up and running and i can still connect to its tasmota interface via IP.

After updating zigbee2mqtt, when i run it, i get the following error:

[2024-07-08 23:36:02] info: 	z2m: Logging to console, file (filename: log.log)
[2024-07-08 23:36:02] info: 	z2m: Starting Zigbee2MQTT version 1.39.0 (commit #unknown)
[2024-07-08 23:36:02] info: 	z2m: Starting zigbee-herdsman (0.50.1)
[2024-07-08 23:36:02] info: 	zh:zstack:znp: Opening TCP socket with 192.168.1.102:8888
[2024-07-08 23:36:02] info: 	zh:zstack:znp: Socket connected
[2024-07-08 23:36:02] info: 	zh:zstack:znp: Socket ready
[2024-07-08 23:36:02] info: 	zh:zstack:znp: Writing CC2530/CC2531 skip bootloader payload
[2024-07-08 23:36:03] info: 	zh:zstack:znp: Skip bootloader for CC2652/CC1352
[2024-07-08 23:36:21] error: 	z2m: Error while starting zigbee-herdsman
[2024-07-08 23:36:21] error: 	z2m: Failed to start zigbee
[2024-07-08 23:36:21] error: 	z2m: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
[2024-07-08 23:36:21] error: 	z2m: Exiting...
[2024-07-08 23:36:21] error: 	z2m: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:101:27)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:129:29)
    at Zigbee.start (/app/lib/zigbee.ts:63:27)
    at Controller.start (/app/lib/controller.ts:139:27)
    at start (/app/index.js:154:5)


Im not entirely sure whats happened here. Any ideas? Current version of zigbee2mqtt 1.37.0-1 works fine, the new 1.39 has the above error.

any help/suggestions appreciated :slight_smile:

Show your Zigbee2mqtt configuration

the z2m config file (/config/zigbee2mqtt/configuration.yaml) looks like this:

homeassistant: true
mqtt:
  server: mqtt://core-mosquitto:1883
  user: addons
  password: <REMOVED>
  keepalive: 60
  reject_unauthorized: true
  version: 4
serial:
  port: tcp://192.168.1.102:8888
frontend:
  port: 8099
advanced:
  homeassistant_legacy_entity_attributes: false
  legacy_api: false
  legacy_availability_payload: false
  log_syslog:
    app_name: Zigbee2MQTT
    eol: /n
    host: localhost
    localhost: localhost
    path: /dev/log
    pid: process.pid
    port: 514
    protocol: udp4
    type: '5424'
  channel: 15
  log_level: info
device_options:
  legacy: false
devices:
  '<REMOVED>':
    friendly_name: plug.proxy.livingroom.1
  ...
  ...
  ...

password and device IDs removed. I have about 50 odd devices, ive removed those from the code above. 192.168.1.102 is the ip for the zigbee gateway (http://192.168.1.102/ brings me to the usual tasmota config page for the gateway).

this is the zigbee gateway im using: https://www.athom.tech/blank-1/zigbee-gateway

As i said earlier, z2m 1.37 works perfectly fine and i have no issues at all, 1.39 throws the above error (1.38 i believe also had the same error - i think i tried updating two weeks ago and had the same issue - luckily i can easily roll back).

Actually looking at it closely,

mqtt:
  server: mqtt://core-mosquitto:1883
  user: addons
  password: <REMOVED>

I dont have a user in HA called “addons”. Could that be the cause, hmm?