Error during setup of component asuswrt

I try to use the asuswrt component but fails.
I get this in the log file, I would really appreciate if someone can help!
Regards S

Error during setup of component asuswrt
Traceback (most recent call last):
File “/usr/local/lib/python3.7/site-packages/homeassistant/”, line 151, in _async_setup_component
hass, processed_config)
File “/usr/local/lib/python3.7/site-packages/homeassistant/components/asuswrt/”, line 48, in async_setup
conf = config[DOMAIN]
KeyError: ‘asuswrt’

you’ll need to post your config so we can see any errors.

Router is a Asus RT-AC68U and ssh works from Putty with username and passwd


– platform: asuswrt
protocol: ssh
username: myusername
password: mypassword
track_new_devices: true
interval_seconds: 30
consider_home: 90

nano known_devices.yaml

#This file I created empty and then it was populated automatically
#perhaps when I tried to call the se “device_tracker.see” service
#from development tools - here I used “mac”: “adress” attribute without success
hide_if_away: false
mac: 01:23:45:67:89:ab
name: 01 23 45 67 89 ab
track: true

did you add the main asuswrt component to your configuration.yaml, too?

you will then remove the login details from the configuration of the device_tracker that you posted above. the only thing you should end up with in the device tracker is:

  - platform: asuswrt
    interval_seconds: 30
    consider_home: 90
      track_new_devices: False
      #hide_if_away: False
1 Like

I know OP never replied to your comment, but I wanted to let you know you solved my problem :slight_smile:

1 Like