Error during update hassio from 0.107.0 to 0.107.3

I tried to update from the UI but after pushing the “Update” button I received the error “Error: Unknown Error, see logs”. When I lookedIN the HA logs I saw this message.

20-03-20 20:43:56 ERROR (SyncWorker_9) [supervisor.docker.interface] Can’t install homeassistant/qemux86-64-homeassistant:0.107.3 -> 500 Server Error: Internal Server Error (“Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)”).
20-03-20 20:43:56 WARNING (MainThread) [supervisor.homeassistant] Update Home Assistant image fails

I’ve tried a few things:

  1. Rebooting the entire server
  2. Checking Disk space, but the disk is 52% full
  3. Executing the command ‘hassio su repair’

Still got the same error after these options.

Does anyone got an idea? Running Hassio on a Intel NUC with Ubuntu 18.x on it.

Same here, from 0.107.1 to 0.107.3
Hassio running on Ubuntu server 18.04.4 LTS ( docker ), os_version: 4.15.0-91-generic.
Hardware Intel i7 8550U, 16MB ram, 128Gb SSD industrial PC.
The link to the server file are not available, so i can’t check if the error ( 500 Internal Server Error on Apache or IIS web server ) are real…

https://registry-1.docker.io/v2/
{“errors”:[{“code”:“UNAUTHORIZED”,“message”:“authentication required”,“detail”:null}]}

Update is possible on the Rapsberry Pi version.

Check DOCKER DNS ( Domain Name Resolution server address ):
List all DNS server connection related:

sudo nmcli con

Get the DOCKER one:

nmcli con show docker0 | grep ipv4.dns

Add new DNS to the Docker connection. ( May be you need to be Super User )

( sudo su )
nmcli con mod docker0 ipv4.dns “8.8.8.8 8.8.4.4”

Update…

Because i don’t know the CORE infrastructure too much please, someone, comment this post !

Thanks for thinking with me.

The “nmcli con” comments gives no results for me. I’m running Hassio on a Ubuntu host, that creates dockers container for me.

Hi Ruald, the problem seems to be common….



https://development.robinwinslow.uk/2016/06/23/fix-docker-networking-dns/

so the first thing, at least for me, is find the cause… If i can’t get the IP from the DNS i can’t connect with the server so the authentication fail….

Someone have problem with user credential… Group docker

PS: i used the hassio-installer script to install :slight_smile: my Home Assistant software:

I’ve tested from the HassIO command line. Internet en DNS both works fine.

I can ping the Google DNS 8.8.8.8 and I can ping a dutch news site nu.nl. So that error “500 Server Error: Internal Server Error” must got other reason.

Docker seems to be like a virtual machine with own virtual interfaces… Docker isolate the container from the OS… So if ping respond, on the OS is OK but the container use a different “network”…

I don’t remember… type exit or quit in the SSH terminal if you use them…

Thake a look to the links i have posted… like:

Thanks for that. I’ve been successfully trying a few docker diagnostic commands. Again not sure what they tell me yet

docker run busybox ping 192.203.230.10

Hey did you find a solution to this?