ERROR ESP requests password, but no password given!


#1

I have a D1 mini and connected to it using ESPhome add-on under HASSIOI by way of USB for the first time. I have a program ready to load using ESPhome but when I try to use OTA under the Upload command it comes up with this error

ERROR ESP requests password, but no password given!
any ideas? Thanks


#2

does anyone know that I can check


#3

did you load the sketch over USB for the 1st time?
you can’t do OTA for the first time, has to be USB
I don’t use hass.io i did my install via cli in linux via usb then OTA after that.


#4

In the top right of the web ui for esphome there is the option to use OTA of a serial/usb port. Choose usb port for the first upload.


#5

I already did the USB for the first time, but I had to use a different machine as my HASSio box won’t see the USB. Still keep getting the about error…password thing I think I’ve tried everything. Not sure where it picks up password because I didn’t set one up


#6

Use USB again and make sure you set the ota password properly this time.


#7

I’m trying that right now, I’ll let you know. Thanks for your reply


#8

I was able to connect OTA by setting OTA password, all looked good until I made changes to device which is a D1 mini, I added the IP, Gateway and Subnet and uploaded. So far all good next I made changes, adding GPIO stuff to make the D1 work, then I uploaded I now get this message

ERROR Connecting to 192.168.1.118:8266 failed: timed out

I tried ping the D1 mini’s IP and I get no response it’s not connecting to wifi, it did how ever before I uploaded the last time I was able to ping the D1 mini.


#9

If you are manually assigning an ip make sure it’s not being used by another device. I had this issue. Now i just let mdns take care of it.


#10

I’m using the IP that my router see and assigning the D1 to that. I think some how the wifi is turning off on the board. I’m thinking that after a D1 mini gets flashed it has to do a reset. I’ll look into that procedure because how would the wifi just shut down after a flash. Maybe it stuck in some process